Crashes when sending a message.

RESOLVED WORKSFORME

Status

MailNews Core
Networking: SMTP
--
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Jake, Assigned: Scott MacGregor)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Not sure, but it might be due to MSN SMTP servers.

Reproducible: Always

Steps to Reproduce:
1. SEND
2. A
3. MESSAGE ;)

Actual Results:  
CRASHED

Expected Results:  
sent the message
more informations please (like a talkback ID or a stack trace from a debug build)

Comment 2

15 years ago
It's possible this could be a replica of bug 186320.

Here are some recent nightly TB ids:

TB15939027X, TB15938841H, TB15938791Z, TB15938732K, TB15938703M

Comment 3

15 years ago
This is happening to me with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.3b) Gecko/20030123.

Crash ID:

TB16540884E, TB16540620Y, TB16540243Z, TB16539866E

Comment 4

15 years ago
Turing off automatic spell check fixed this for me...  Good call on the bug
reference.

Updated

15 years ago
Keywords: crash, stackwanted

Updated

15 years ago
Blocks: 193931

Comment 5

15 years ago
Reporter, to troubleshoot this problem, please follow these steps. When you
reply, make sure to include your operating system version, and the build ID. The
build ID is located in the Mozilla title bar. If the problem is sovled, please
indicate what step solved it.

1. Make sure that the test machine you're running is in good condition. On
Windows 9x, run scandisk. On Windows NT/2000/XP, error-check the drives. On
*nix, check for filesystem errors. Furthermore, if you have an antivirus
program, make sure the antivirus definitions and program files are up to date.
Make sure you have recently scanned the system for viruses, and removed any you
find. Once this is complete, can you still reproduce the problem?

2. Download and install the latest trunk nightly build.  Running a nightly build
has a slight amount of risk involved. Back up your Mozilla data including your
bookmarks before proceeding. You can download the latest nightly build from
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest . For example, for Windows,
download the file mozilla-win32-installer-sea.exe. Uninstall your current
Mozilla build. Make sure the new directory where you will install the new build
is completely empty, except for any plugins subdirectory. Install the nightly
build. Having done that, can you still reproduce the problem?

3. If it still fails, exit Mozilla. Go to your profile directory. Find the file
xul.mfl (or xul.mfasl on *nix). Rename it. Restart Mozilla. Does that solve the
problem?


Before following the next steps, create an SMTP log. Attach the SMTP log to this
bug. The steps for creating the log can be found here:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap


4. Is the computer you are running Mozilla on running an antivirus program? If
so, please detail what program and what version it is. Temporarily disable the
antivirus program. Then try to reproduce the problem you describe. Does the
problem still occur?

5. Go to Edit | Mail & Newsgroup Account Settings | Outgoing Server (SMTP) and
check "never" on whether to use a secure connection (SSL). Now try to reproduce
the problem. Does it still occur?

6. Go to Edit | Mail & Newsgroup Account Settings. In the appropriate account,
under Copies & Folders, unselect "place a copy in." Now try to reproduce the
problem. Does it still occur? If this works, is this an IMAP account? Are there
many messages in the sent folder?

7. Is the computer behind a firewall? If so, temporarily disable it, or put the
computer directly on the Internet. Can you still reproduce the problem? If not,
what product and version number is the firewall?

8. Delete all your SMTP server entries. Exit Mozilla. Restart Mozilla. Recreate
all your SMTP server entries. Can you still reproduce the problem?

9. Do you have spellchecker installed? If so, disable it or remove it. Does that
solve the problem?

If none of these steps work, please attach an SMTP log. 
no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.