Conn: IP renumbering causes network to go deaf

VERIFIED WORKSFORME

Status

()

Core
Networking
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Jan, Assigned: dougt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021217

After the IP of my machine has changed (DSL and dyndns), I can't access the web
page of it. It works with every browser (lynx, netscape4, ie) from every machine
(this machine, local network and non-local network). Status bar says:
"Connecting to chef.is-a-geek.net..." and some time later a msg appears:
"Connection refused...". Even if I type the IP in, the same thing happens. After
reboot there is no problem in accessing the page. Sorry for bad english...

Reproducible: Always

Steps to Reproduce:
1. Start router
2. Start normal Computer
3. disconnect from internet, connect to internet

Actual Results:  
The Browser refuses to connect to the routers webpage

Expected Results:  
connect to the routers webpage
Does it also not work if you restart mozilla or select File|Work Offiline,
File|Work online ?
(Reporter)

Comment 2

16 years ago
Neither File|Work Offiline, File|Work online nor restarting Mozilla work.

Comment 3

16 years ago
Probably a general networking issue, not just HTTP.

Can you see if FTP has the same problem?
Assignee: darin → dougt
Component: Networking: HTTP → Networking
QA Contact: httpqa → benc
Summary: Can't access page (only Mozilla) → Conn: Can't access page (only Mozilla)
(Reporter)

Comment 4

16 years ago
There is no FTP-Server on this machine.

I'm not sure any more that it is a bug in Mozilla (sorry if that is true). I've
tested the connection with lynx and netscape 4 (same machine/linux) and it
worked.  IE seemed to work but showed only a cached page. Neither IE nor Mozilla
connect to the router. If it helps: SSH, Telnet and Ping are working...

Comment 5

16 years ago
What I meant by FTP, is only http broken, or do ftp: URL's like
"ftp://ftp.mozilla.org" also have problems in the same situation

Does the problem go away if you quit and restart just Mozilla (but not the
operating system?)
Summary: Conn: Can't access page (only Mozilla) → Conn: IP renumbering causes network to go deaf
(Reporter)

Comment 6

16 years ago
I can access all sites (http, ftp, irc) but not the router's web site. After
restarting Mozilla the problem is still there.

Comment 7

14 years ago
Reporter, do you still see this problem with the latest nightly (or even 1.7.3)?
If not, this bug has probably been fixed and can be closed. Thanks.

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 8

14 years ago
No bug / patch specified as the fix.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Comment 9

14 years ago
Oops!  Sorry.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Comment 10

13 years ago
V/WFM
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.