Closed Bug 1864521 Opened 8 months ago Closed 8 months ago

No longer connecting to Mac OSX addressbook

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 120
x86_64
macOS
defect

Tracking

(thunderbird_esr115 unaffected, thunderbird121 fixed, thunderbird122 affected)

VERIFIED FIXED
122 Branch
Tracking Status
thunderbird_esr115 --- unaffected
thunderbird121 --- fixed
thunderbird122 --- affected

People

(Reporter: mitra_lists, Assigned: rjl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Since upgrading to 120b5 TB has stopped connecting to the Mac OSX Address book/Contacts,

The symptom is that it no longer autocompletes most email addresses - the ones it was previously getting from OSX

You can check if this is the case by going to the Address Books (top left on the sidebar) then "Mac OS X Address Book" , it says "No contacts available".

When I go to System Preferences / Privacy / Contacts it doesn't list TB (I presume it used to) which suggests to me like TB isn't requesting access to the contacts ?

Restarting TB, or the Contacts didn't help.

This also impacts filters of course, many of mine are based on whether or not an email address is in the address book.

See also #1831673 and #1847536 about slow startup, which have been reported fixed, but look like its just because TB is no longer importing the address book at startup.

Can you get a regression window? https://github.com/mozilla/mozregression is helpful

I was on 119.0b1 before upgrading. I missed the earlier release on 120.0b1..5. I do notice that both myself and piotr just reported this problem on 120.0b5 - by reporting that the slow startup bugs (#1831673 and #1847536 ) were fixed - which was due to it taking forever (as long as 3 mins in my case) to access the Contacts.

I tried going back to 119.0b1 but got into problems with TB wanting me to create a new profile because of the down-version shift. This is my work environment so I can't risk this kind of test blowing my 37GB of email up (as has happened before), and I don't have a separate test machine.

FWIW, you can start with --allow-downgrade to get around that.
For testing this bug you could also just set up a dummy profile (start with the -p flag and create one) - since you don't need any data.

I'm sorry but I think you need to be more specific .... on a Mac we don't give things flags, we start from the Applications directory.

I tried to guess,
cd /Applications/Thunderbird 1190b1.app/Contents/MacOS ; ./thunderbird -p
but it gave me a dialog box to pick an existing profile, and it gives a choice between default-beta default-beta-1 default or Create Profile. Create-profile sits in a loop with an error in the console

2023-11-16 18:48:42.148 thunderbird[96147:1921310] Rethrowing (from nts_ValueForProperty:) NSInternalInconsistencyException: Unhandled error (NSCocoaErrorDomain, 134092) occurred during faulting and was thrown: Error Domain=NSCocoaErrorDomain Code=134092 "(null)"
CoreData: error: Unhandled error occurred during faulting: Error Domain=NSCocoaErrorDomain Code=134092 "(null)" ({
})

Wouldn't it be better for someone with a development environment, and familiarity with this, to do this regression. rather than those of us with only a profile with sensitive work in it trying and guessing (note I have previously trashed my email - costing me significant amount of work to rebuild - trying to follow similar testing process, so this isn't just an idle worry).

I'm presuming that any developer with a Mac can replicate the issue with 120.0b5 with it not connecting to the Address book. ?

Duplicate of this bug: 1865024
Assignee: nobody → rob
Status: NEW → ASSIGNED
Regressed by: 1853891
Target Milestone: --- → 122 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/65b99b9ad3d0
[macOS] Restore the addressbook entitlement for releases. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

Confirmed the fix is working with Daily from 2023-12-06.

Status: RESOLVED → VERIFIED

Comment on attachment 9366956 [details]
Bug 1864521 - [macOS] Restore the addressbook entitlement for releases. r=#thunderbird-reviewers

[Triage Comment]
Approved for beta

Attachment #9366956 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: