Closed Bug 1864582 Opened 6 months ago Closed 6 months ago

Don't save folder sort order value if no siblings have an order value

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1846550

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 obsolete file)

If a new folder is added, and none of its siblings have ever been sorted, we should not set a sort order value on the new folder. Currently we do set a value, and this causes any new folders to be added to the start of the list instead of in the natural order.

I think I coded it that way. But it isn't? I will look into it.

Ah, I see. It still invoke the DB, even if we do set same value. My bad.

I meant to say in the first comment that this causes the test failure we've been seeing in mail/base/test/browser/browser_folderTreeQuirks.js. It deletes (in order) folderX, folderY and folderZ. The folders then appear in the list (as subfolders of the trash folder) in the order folderZ, folderY and folderX.

Duplicate of this bug: 1864510

Duping this into 1846550 as the original fix got backed out and this fix should be baked into the main one before it relands.

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Duplicate of bug: 1846550
Resolution: --- → DUPLICATE
Attachment #9363410 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: