Closed Bug 1864804 Opened 7 months ago Closed 6 months ago

[CSS round] round up not equal to down when valueToRound integer multiple of roundingInterval

Categories

(Core :: CSS Parsing and Computation, defect)

Firefox 119
defect

Tracking

()

RESOLVED DUPLICATE of bug 1859048

People

(Reporter: 94529818, Unassigned)

Details

Steps to reproduce:

CSS:
round(down, 100px, 1px) equals to 100px
round(up, 100px, 1px) equals to 101px

Actual results:

up round isn't equal down.

Expected results:

According to the document:
If valueToRound is exactly equal to an integer multiple of roundingInterval, round() resolves to valueToRound exactly.

It should got same result (100px in example)

Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core

The severity field is not set for this bug.
:TYLin, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(aethanyc)
Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Duplicate of bug: 1859048
Flags: needinfo?(aethanyc)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.