If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Downloading any file causes Mozilla to crash when focus is switched [@ nsAppShell::DispatchNativeEvent ]

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: lsof, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

When I open a non-displayable page (e.g. a gzipped file) in a new tab, a tab is
created called (Untitled), a dialog box appears and I can save the file.
However, if I manage to switch windows just before the download dialog grabs
focus, I cannot see the window.
So I minimize Mozilla, and see it. I cannot save the file.
I switch back to the main Mozilla window, and the dialog box is now there. I
click save, Mozilla crashes.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
can you post Talkback ID for this crash
"mozilla/bin/components/talkback/talkback" or a stack trace using GDB and a
debug build ?
Keywords: crash, stackwanted
(Reporter)

Comment 2

15 years ago
Created attachment 109953 [details]
Stack trace for crash with Moz 1.0.1

Will test using later version shortly.

Comment 3

15 years ago
indeed, try latest trunk or 1.0.2 candidate builds:
http://ftp.mozilla.org/pub/mozilla/nightly/latest-1.0/
http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/
Keywords: stackwanted
Summary: Downloading any file causes Mozilla to crash when focus is switched → Downloading any file causes Mozilla to crash when focus is switched [@ nsAppShell::DispatchNativeEvent ]
(Reporter)

Comment 4

15 years ago
1.3a seems fine (well, almost) with this - it doesn't crash, but the download
dialog box is unresponsive unless it a cancel is hit a lot of times.

Here's some better info to reproduce the problem.
1. Go to two websites, one with a link to a .tar.gz (or similar) file.
2. Click the link to download the file, and straight away start switching
between the tabs. The download dialog box will lose focus.
3. Switch to download dialog box, try to save. It won't.
4. Switch back to main Mozilla window - the dialog is there as well! Click save.
 .. Previously nothing happenned here, 1.3a lets me save.
(Reporter)

Comment 5

15 years ago
change "previously, nothing happenned here" to "previously, crash"
(Reporter)

Comment 6

15 years ago
and change "lets me save" to "does nothing".

Lowering priority from critical to major since no crash happens.
I can't 'lose data' because I can't get the file I'm trying to download.
Severity: critical → major

Comment 7

15 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: major → critical

Comment 8

14 years ago
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4rc3)? 

If so, then please comment again with details. 
If not, then please resolve this bug as WORKSFORME. Thanks.
(Assignee)

Comment 9

14 years ago
unable to reproduce with latest trunk nightly build. Please reopen if you can
reproduce with 1.6 or newer. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
Crash Signature: [@ nsAppShell::DispatchNativeEvent ]
You need to log in before you can comment on or make changes to this bug.