Closed Bug 18651 Opened 20 years ago Closed 20 years ago

[PERF]reloads take longer and longer

Categories

(SeaMonkey :: General, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: colin, Assigned: rickg)

References

()

Details

Attachments

(1 file)

This is with the 1999111108 Linux build (I first noticed this problem
on my OpenVMS build, but its reproducible on Linux).

Load "about:blank". Hit the reload button. See how long it takes to reload.
Now keep hitting reload. You don't need to wail on the button, you can wait
for the reload to finish. Repeat. Repeat some more. The timings are somewhat
random, but if you keep reloading, you'll notice that the times slowly go
up. You'll probably need to reload 30-40 times to see a significant increase.

Same is true for any page. I'm only using about:blank cos it rules out
network variances.

What's going on here?
Assignee: leger → rpotts
Summary: reloads take longer and longer → [PERF]reloads take longer and longer
I found one problem where each time about:blank was loaded, it would leak a
nsFileTransport and all of its associated objects...

This was  happening because about:blank was loading *before* the throbber image
could finish loading.

So, imagelib would cancel the throbber load by returning NS_BINDING_ABORT.
However, the FileChannel had already filled up the InputStream and blocked
waiting for ImageLib to consume the data.

Since, imagelib had canceled the request, it never got another notification, and
the nsFileTransport just hung out in a suspended state...

I added a call to Cancel() the transport if OnDataAvailable fails...

This stopped the nsFileTransport (et al) leaks...
Assignee: rpotts → rickg
Target Milestone: M14
Rick says that this no longer appears to be network related, but there's still a
slow-down going on. Probably layout related. => rickg
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Unable to reproduce this problem. Sigh.
Marking Verified as WorksForMe.  We are rockin on blank and general page load 
now! Please use latest nightly build from: http://www.mozilla.org/binaries.html 
and reopen bug if is happens again.  Thanks!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.