panacea.dat and prefs.js store the path to mail folders as absolute, not relative paths

RESOLVED DUPLICATE of bug 196119

Status

MailNews Core
Import
RESOLVED DUPLICATE of bug 196119
15 years ago
9 years ago

People

(Reporter: Richard Neill, Assigned: Cavin Song)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

The files panacea.dat and prefs.js store the paths to mail folders as absolute
paths, not relative paths. This causes hell when trying to restore your old mail
from a backup into a freshly created profile with different salting.

I've given more details and a workaround in my comments in bug 63389

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Expected Results:  
Store all paths in the profile as relative paths with respect to foo123bar.slt

This wouldn't be so bad if you could create a new profile, then change the name
of the salting directory.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 196119 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.