Closed Bug 1865806 Opened 5 months ago Closed 5 months ago

blank 3pane when starting up with unsent messages in outbox

Categories

(Thunderbird :: Mail Window Front End, defect)

defect

Tracking

(thunderbird_esr115+ wontfix, thunderbird121 fixed)

RESOLVED FIXED
122 Branch
Tracking Status
thunderbird_esr115 + wontfix
thunderbird121 --- fixed

People

(Reporter: mkmelin, Assigned: mkmelin)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

On trunk if I have messages in the outbox, when starting up I get a blank 3pane.

Uncaught (in promise) TypeError: aNode.reset is not a function
    reflectInDOM resource:///modules/QuickFilterManager.jsm:1233
    reflectFiltererState chrome://messenger/content/quickFilterBar.js:408
    _showFilterBar chrome://messenger/content/quickFilterBar.js:538
    init chrome://messenger/content/quickFilterBar.js:102
    init chrome://messenger/content/about3Pane.js:4325
    <anonymous> chrome://messenger/content/about3Pane.js:110
    openWindowPrompt resource:///actors/PromptParent.jsm:163
    receiveMessage resource:///actors/PromptParent.jsm:103
    openPrompt resource://gre/modules/Prompter.sys.mjs:1187
    openPromptSync resource://gre/modules/Prompter.sys.mjs:1031
    confirmEx resource://gre/modules/Prompter.sys.mjs:1465
    confirmEx resource://gre/modules/Prompter.sys.mjs:297
    confirmSendUnsentMessages chrome://messenger/content/mail-offline.js:128
    shouldSendUnsentMessages chrome://messenger/content/mail-offline.js:169
    loadStartFolder chrome://messenger/content/messenger.js:888
2 QuickFilterManager.jsm:1233:13
Uncaught (in promise) TypeError: can't access property "contentWindow", win.messageBrowser is undefined
    openTab chrome://messenger/content/mailTabs.js:103
2 mailTabs.js:103:13

aNode.reset() should work, it's just that the search-bar custom element has not yet had enough time to be registered

I had seen this error sometime in the past intermittently, but now it was all the sudden reproducible. Some unrelated timing may have changed to make it more exposed.

Target Milestone: --- → 122 Branch

Pushed by alessandro@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/aebcb6b00fdc
Prevent blank 3pane when starting up with unsent messages in outbox. r=freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Comment on attachment 9364699 [details]
Bug 1865806 - Prevent blank 3pane when starting up with unsent messages in outbox. r=elizabeth,freaktechnik

[Approval Request Comment]
Regression caused by (bug #): unknown, unknown if it's a regression or if it's only happening during certain specific timings
User impact if declined: blank 3pane on startup
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): safe

Attachment #9364699 - Flags: approval-comm-esr115?
Attachment #9364699 - Flags: approval-comm-beta?
Severity: -- → S2

Comment on attachment 9364699 [details]
Bug 1865806 - Prevent blank 3pane when starting up with unsent messages in outbox. r=elizabeth,freaktechnik

[Triage Comment]
Approved for beta

Attachment #9364699 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9364699 [details]
Bug 1865806 - Prevent blank 3pane when starting up with unsent messages in outbox. r=elizabeth,freaktechnik

[Triage Comment]
Approved for esr115

Attachment #9364699 - Flags: approval-comm-esr115? → approval-comm-esr115+

Right, there's the "JavaScript error: chrome://messenger/content/mailTabs.js, line 103: TypeError: win.messageBrowser is undefined" error logged. So some other timing is different on 115.

I think we can just drop this for 115 then. It was a bit unclear if it's affected at all.
Please just back out for 115.

Flags: needinfo?(rob)

Was backed out in comment 9.

Flags: needinfo?(rob)

Comment on attachment 9364699 [details]
Bug 1865806 - Prevent blank 3pane when starting up with unsent messages in outbox. r=elizabeth,freaktechnik

Resetting approval flag as this is now WONTFIX

Attachment #9364699 - Flags: approval-comm-esr115+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: