WIndows XP - 'Back' and 'Forward' buttons not working

RESOLVED WORKSFORME

Status

()

Core
XUL
--
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: dave, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

 Upgrade from Win98SE to WIndows XP cause back/forward options (buttons, "go"
history, right mouse click) to stop functioning. Have both Mozilla 1.2.1 AND
netscape 6.2 on the computer, both worked in Win 98SE.

Reproducible: Always

Steps to Reproduce:
1. GO to a URI. 
2. Click on a link or anything to take you to another location


Actual Results:  
 Unable to use Back Button, Forward button, right mouslcick and "go" drop down
menus these options are greyed out in BOTH Mozilla 1.2.1 AND Netscape 6.2

Expected Results:  
 Go forward or go back.

SOLUTION: After 3 days of searching for some setting in Mozilla I went inot
Netscape and look at the settings. Preferences > Navigator > History. There is
an option called "Session History". This was set a 0 (zero). This is not an
option in Mozilla 1.2.1. So I changed it to 6 (six) and there it is - both
Netscape 6.2 AND Mozilla 1.2.1 now have ther forward and back options working
again. 

 This was not a problem in Windows 98SE. It only happened after the upgrade. So
is this an XP problem? Did XP change settings? Mozilla does not have this option
available but Netscape does and obviously it affects Mozillas setting...so does
this mean that Mozilla affects Netscapes settings as well?
yes, they use the same profile.

This option is also in Mozilla : edit\preferences\navigator\history\Browsing
History.

Reporter: Please search before you file a bug. You got a little iframe with
known busg as you filed your bug. 
The URL ist : http://bugzilla.mozilla.org/duplicates.cgi and you can see there 
bug 126826 "'Back' and 'Forward' buttons not working"

*** This bug has been marked as a duplicate of 126826 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
 First I did search for the same bug. While I did get hits for
"back/Forward" buttons I did not get any hits for an upgrade from
Windows 98SE to WIndows XP causing the Problem. Also I did not see any
mention of the "solution" being tied to Netscape 6.2. Thusly I submitted
the bug. 

 Per Mozilla having the same options - this is not true. I am looking at
it right now.
Mozilla 1.2.1 = edit > preferences > navigator > history > Browsing
History. There are two options. Browsing History and Navigator History.
Neither of these options made any chages to the back forward buttons
when I changed values.

 netscape 6.2 = edit > preferences > navigator > history > Browsing
History we have 3 options. Browsing History, Location Bar History and
Session History. Browsing History is the same and as far as I can see
the Navigator History and Location Bar History are the same. The Session
History in Netscape is not an option in Mozilla. Perhaps it is in the
latest nightly build but not in the latest "stable" release of 1.2.1

 I was trying to be helpful with a solution because I could not find any of 
this information when I searched for how to reolve this problem. I was happy to 
see other people finding the same bug. Hopefully I provided a solution to it.
However I can not provide information as to why this only affected the
browsers in Windows XP and not Windows 98SE in my case. In the other
cases I read they were Windows 2000 and NT OS's affected, so it seems to affect 
the NT OS's only? This to me is a valid bug more than just a back/forward bug 
it seems to be an OS bug combined with Netscape and Mozilla sharing options.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
-> wfm

(works with a current trunk on win2k)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.