Searching from URL bar causes "invalid URL" dialog

VERIFIED DUPLICATE of bug 135363

Status

SeaMonkey
Location Bar
VERIFIED DUPLICATE of bug 135363
16 years ago
10 years ago

People

(Reporter: Matt Bridges, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

If I just hit enter after putting some search terms in the location bar by
mistake (instead of hitting down + enter, to highlight the search option in the
autocomplete bar), I can no longer select the "search google for ..." option in
the autocomplete dropdown using the keyboard, only using the mouse.

Reproducible: Always

Steps to Reproduce:
1.Enter search terms (w/ a space; multiple words, i.e. 'mozilla web browser') in
the URL bar
2.Hit enter; a dialog about invalid URL comes up.  Hit 'enter' to get rid of dialog
3.use mouse to put cursor back in URL bar
4.Hit down twice so that "search google for ..." is highlighted
5.Hit enter

Actual Results:  
The "Invalid URL" dialog appears

Expected Results:  
Search Google w/ the keywords entered

It does work if you use the mouse to click on "Search Google for ..." instead of
highlighting that option and pressing enter.

It would also be nice if dismissing the "invalid url" dialog put the cursor
focus back in the address bar -- its annoying to have to use the mouse or tab
back into the address bar when you type in an invalid URL -- but thats a
seperate issue probably.

Comment 1

16 years ago
This has been fixed a few days ago. Please try a more recent build.

*** This bug has been marked as a duplicate of 135363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
VERIFIED DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.