Closed Bug 1866598 Opened 8 months ago Closed 8 months ago

Perma [tier 2] browser/components/firefoxview/tests/browser/firefoxview-next/browser_firefoxview_next_navigation.js | Node is not accessible via accessibility API: id: , tagName: BUTTON, className: -

Categories

(Firefox :: Firefox View, defect, P5)

defect

Tracking

()

RESOLVED FIXED
122 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox120 --- unaffected
firefox121 --- unaffected
firefox122 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: ayeddi)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, intermittent-testcase, regression, Whiteboard: [retriggered][stockwell disable-recommended])

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=437638509&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Uv3IpmnxTge6ND0BrdFcHw/runs/0/artifacts/public/logs/live_backing.log


[task 2023-11-25T00:24:04.400Z] 00:24:04     INFO - TEST-PASS | browser/components/firefoxview/tests/browser/firefoxview-next/browser_firefoxview_next_navigation.js | The correct deck child is selected - 
[task 2023-11-25T00:24:04.401Z] 00:24:04     INFO - Clicking navigation button for history
[task 2023-11-25T00:24:04.402Z] 00:24:04     INFO - Buffered messages finished
[task 2023-11-25T00:24:04.409Z] 00:24:04     INFO - TEST-UNEXPECTED-FAIL | browser/components/firefoxview/tests/browser/firefoxview-next/browser_firefoxview_next_navigation.js | Node is not accessible via accessibility API: id: , tagName: BUTTON, className:  - 
[task 2023-11-25T00:24:04.410Z] 00:24:04     INFO - Stack trace:
[task 2023-11-25T00:24:04.411Z] 00:24:04     INFO - chrome://mochikit/content/browser-test.js:test_ok:1587
[task 2023-11-25T00:24:04.412Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/AccessibilityUtils.js:a11yFail:392
[task 2023-11-25T00:24:04.412Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/AccessibilityUtils.js:assertCanBeClicked:721
[task 2023-11-25T00:24:04.413Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/AccessibilityUtils.js:runIfA11YChecks/this.AccessibilityUtils:700
[task 2023-11-25T00:24:04.414Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/AccessibilityUtils.js:handleEvent:807
[task 2023-11-25T00:24:04.414Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/EventUtils.js:synthesizeMouseAtPoint:758
[task 2023-11-25T00:24:04.415Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/EventUtils.js:synthesizeMouse:565
[task 2023-11-25T00:24:04.416Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/EventUtils.js:synthesizeMouseAtCenter:846
[task 2023-11-25T00:24:04.416Z] 00:24:04     INFO - chrome://mochitests/content/browser/browser/components/firefoxview/tests/browser/firefoxview-next/browser_firefoxview_next_navigation.js:test_side_component_navigation_by_click/<:38
[task 2023-11-25T00:24:04.417Z] 00:24:04     INFO - resource://testing-common/FirefoxViewTestUtils.sys.mjs:withFirefoxView:145
[task 2023-11-25T00:24:04.418Z] 00:24:04     INFO - chrome://mochitests/content/browser/browser/components/firefoxview/tests/browser/firefoxview-next/browser_firefoxview_next_navigation.js:test_side_component_navigation_by_click:22
[task 2023-11-25T00:24:04.418Z] 00:24:04     INFO - chrome://mochikit/content/browser-test.js:handleTask:1138
[task 2023-11-25T00:24:04.419Z] 00:24:04     INFO - chrome://mochikit/content/browser-test.js:_runTaskBasedTest:1210
[task 2023-11-25T00:24:04.420Z] 00:24:04     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1352
[task 2023-11-25T00:24:04.420Z] 00:24:04     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1127
[task 2023-11-25T00:24:04.421Z] 00:24:04     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/<:1058
[task 2023-11-25T00:24:04.422Z] 00:24:04     INFO - TEST-PASS | browser/components/firefoxview/tests/browser/firefoxview-next/browser_firefoxview_next_navigation.js | Navigation button for history navigates to about:firefoxview-next#history on click. - 

Set release status flags based on info from the regressing bug 1836474

See Also: → 1858041
Depends on: 1867378

(In reply to Natalia Csoregi [:nataliaCs] from comment #10)

There is another failure on the same file path: TEST-UNEXPECTED-FAIL | browser/components/firefoxview/tests/browser/firefoxview-next/browser_firefoxview_next_navigation.js | Node is not focusable via the accessibility API: id: , tagName: FXVIEW-CATEGORY-BUTTON, className: category -

Since those are related to the bug 1867170 changes to the AccessibilityUtils, and the general case of the <fxview-category-button> and other navigation sidebar-related focusability false-positive a11y-check fails, I'll send the patch to temporarily skip those 2 tests while I'm completing the bug 1867378 work to avoid these false-positives. The bug 1867378 patch would also include removing those temporary skip-ifs from the Fx View manifest too. Thank you all for your patience!

Assignee: nobody → ayeddi
See Also: → 1867170

There are 2 tests that are related to the bug 1867170 changes to the AccessibilityUtils, and the general case of the <fxview-category-button> and other navigation sidebar-related focusability false-positive a11y-check fails. We are temporary add skip-if condition to these two failing tests while we continue working on the bug 1867378 work to fine-tune the AccessibilityUtils. The bug 1867378 patch would also include removing those temporary skip-ifs from the Fx View manifest too.

Related Firefox View bugs:

  • Disabling tests: meta bug 1854625
  • Investigation and remediation for components with disabled tests: meta bugs 1854625 and 1858041
  • Explore capturing click events for a11y_checks: bug 1692110
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/220283514882
Temporary fail-if two Tier 2 a11y-checks for Firefox View side navigation. r=fxview-reviewers,sfoster
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 122 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: