Linux: ALT + Left-click no longer opens save dialog

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: David P James, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021223 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021223 Phoenix/0.5

For quite some time the Linux version of Phoenix has ceased opening the save
dialog when ALT + Left-clicking on a link. Right-click and selecting Save Link
As still works however. I'll try to track down at which build this functionality
ceased to work.

This is Linux-only; equivalent Windows builds are functionning correctly.

Reproducible: Always

Steps to Reproduce:
1. Hold down ALT whilst left-clicking a link in Linux

Actual Results:  
Nothing happens

Expected Results:  
Phoenix should have opened the save dialog
(Reporter)

Comment 1

16 years ago
I thought this worked with 0.4, but apparently not after I tested it just now.
I'm not going to be able to track down the failure hinge build as it would have
been sometime in October, 2002.

Comment 2

15 years ago
I've heard a report that this is fixed now.  If not, reopen.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

15 years ago
No, still no go in recent builds with a new profile. In KDE it does make a
window-opening noise however, which suggests that *something* is happening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

15 years ago
Oddly: Ctrl-Left does it for me

Comment 5

15 years ago
Confirming bug still present in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b)
Gecko/20030804 Mozilla Firebird/0.6.1
(Reporter)

Updated

15 years ago
Blocks: 215456

Updated

15 years ago
QA Contact: asa

Comment 6

14 years ago
Seems to be fixed in 0.8.

Comment 7

14 years ago
not fixed in 8.0+  :(

Comment 8

14 years ago
reassign to new default assignee/qa
Assignee: firefox → bugs
Status: REOPENED → NEW
QA Contact: aebrahim

Comment 9

14 years ago
Alt+Left-Click is trapped by most window managers to move the window on Linux.
We can't use this combination in Firefox.

--> WONTFIX

I've opened bug 245015 for finding a replacement.
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WONTFIX
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.