www-Link interpreted as "Download" of html file

VERIFIED DUPLICATE of bug 184975

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 184975
16 years ago
15 years ago

People

(Reporter: blitzreiter, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Html files are not opened but donwloaded. The file does not end up with html or
htm. However Phoenix downloadf manager recognizes the correct format: html.

Reproducible: Always

Steps to Reproduce:
this happens to all users of heise.de with all articles.

1.Open link
http://www.heise.de/tp/deutsch/html/result.xhtml?url=/tp/deutsch/inhalt/kino/13810/1.html

2. Link "Artikel drucken" on this page (="print article" - generates a more
printer friendly html)
http://www.heise.de/bin/tp/issue/dl-artikel.cgi?artikelnr=13810&rub_ordner=inhalt&mode=print

3. html-file is "downloaded" instead of being displayed.
Actual Results:  
I am asked "You have chosen to download a file of type "HyperText Markup
Language" [txt/html] from [..] What should Phoenix do with the file? Open using
an application/ [Button Choose..] Save this file to disk [default]" 

Expected Results:  
Display it within the browser. It works with IE. 

it also happens when you enter link[2] manually in phoenix. 

Html are associated with IE on my computer. So all downloaded files are opened
with IE. However Phoenix opens the html file neither in its own window nor
starts IE.

Comment 1

16 years ago
The HTTP headers of the file contain the following line:

  content-disposition: attachment; filename=13810.html

Asking the user to download the file is the intended behaviour for attachments
(see bug 98360).

*** This bug has been marked as a duplicate of 184975 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
184975 may be related, but this is no graphic, this is a hmtl file!!! 

I know it sometimes happenes with png files with every browser. 
Phoenix asks for an application to open html files with, so that is a strange
behaviour and IE 5.5 does it correctly.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

16 years ago
the file type isn't the problem. The issue here is the same as bug 184975, that
the content-disposition: attachment triggers a download of the file rather than
a display. Image, html file, spreadsheet, whatever. If the content-disposition
is attachment then it's going to trigger a download. That's intended behavior.

*** This bug has been marked as a duplicate of 184975 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Mass verifying of old duplicates.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.