Closed Bug 18674 Opened 20 years ago Closed 17 years ago

Custom install list box behavior is inconsistent with Mac OS HIGs

Categories

(SeaMonkey :: Installer, defect, P2)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: elig, Assigned: slogan)

References

Details

(Keywords: helpwanted, qawanted)

* TITLE/SUMMARY
Custom install list box behavior is inconsistent with Mac OS HIGs

* STEPS TO REPRODUCE
0) Launch the Mozilla installer (Mac OS)
1) Press "Accept" to accept the license, and "Continue" to bypass the welcome
messages.
2) Select "Custom Install" from the pop-up menu in the upper-left hand corner,
and click "Continue".
3) Move the mouse pointer on across the components list box.

* RESULT
 - What happened

The list box selection tracks the mouse movement, without requiring a mouse click
event, in order to dynamically update the component description.

List box selections should not change without an explicit click on behalf of the
user.

 - What was expected

I suspect Simon could suggest a way to tweak the existing UI to accomplish your
intended purpose while retaining consistency with Mac users' expectations.

One easy (albiet cluttered & IMHO ugly) way would be to have an "information"
icon for each list box item, as I believe Apple's installer currently has.

* REGRESSION

 - Occurs On
        Mac OS Apprunner (1999111208-M12 optimized build)


* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
I mentioned this problem to samir already.
Target Milestone: M12
BTW, Samir, when you're tweaking this, I'd encourage you to find a way to
eliminate the need to click 'Continue' after selecting 'Custom Install' to reach
the list of components.

(Every Mac installer I've seen will take you directly to the list.)
Moving non-dogfood bugs to M13
Moving M13 bugs due to Samir's vacation
Target Milestone: M14 → M16
Target Milestone: M16 → M18
I've seen some installers have a little `i' button on the right of the item -- 
clicking it pops up a balloon which describes the component. However, it looks a 
bit cheesy, since it's effectively repetition of command buttons (which is hardly 
ever good UI design).

I think a better solution would be to restrict turning the component on/off to 
the checkbox itself. So:
* clicking anywhere in an item (or using Up/Down keys to get to the item) just
  shows the component description
* clicking on the checkbox itself turns installation of the component on/off.

As for Eli's second point, I agree that the decision on what kind of installation 
you want, and what components you want in the installation (if it's a custom 
one), should be in the same screen, since they're conceptually part of the same 
process.

So, I'd like to see something like this:

Installation type   Components in installation
+---------------+-+ +---------------------------------+-+
|(*) Typical    |A| |Mozilla base (XPCOM)             |A|
|( ) Complete   |:| |Navigator                        |:|
|( ) Custom     |:| |Messenger                        |:|
|               |:| |Composer:::::::::::::::::::::::::|:|
|               |:| |                                 |:|
|               |:| |                                 |V|
|               |:| +---------------------------------+-+
|               |V| Composer: allows you to create Web
+---------------+-+ Web pages and other HTML documents.

And if you choose `Custom', the items in the list get checkboxes so you can turn 
them on/off:

Installation type   Components in installation
+---------------+-+ +---------------------------------+-+
|( ) Typical    |A| |:*: Mozilla base (XPCOM)         |A|
|( ) Complete   |:| |[*] Navigator                    |:|
|(*) Custom     |:| |[*]:Messenger::::::::::::::::::::|:|
|               |:| |[*] Composer                     |:|
|               |:| |[ ] Chatzilla                    |:|
|               |:| |                                 |V|
|               |:| +---------------------------------+-+
|               |V| Messenger: lets you read, write, and
+---------------+-+ organize e-mail and Usenet messages.
updating mac mozilla installer QA contact to me
QA Contact: gbush → asa
Ooh an installer bug m18 w/o nsbeta3. This is dead ;-)

Could someone update the status of the dialog?

On windows I have

( )Browser only
( )Complete
( )Custom
Next>
[ ]Mozilla Navigator
[ ]Mail & News
[ ]Chatzilla
Next>
Keywords: ui
Status: The dialog is just as bad as originally reported, with the same 
components as the Windows one (modulo bug 33355).
What about the list select on mouseover that the reporter was originally 
complaining about? As one of the first bits of UI that the users sees, it does 
give a very bad impression.
Behavior unchanged.
A side effect of using custom System-7-style checkboxes in the list box is that 
they are buggy: if you mousedown on one of the items, then drag out of the 
listbox, the checkbox retains its mousedown appearance.
Those checkboxes are being drawn 'by hand', we're not using real controls. And I 
guess the tracking logic is broken.
Simon is on the money.  The tracking code is broken.  Sorry guys :(  Next 
release :)
Priority: P3 → P2
Unsetting missed milestones to aid triage queries.
Target Milestone: M18 → ---
Over to Syd for installer bug triage
Assignee: sgehani → syd
Status: ASSIGNED → NEW
Target Milestone: --- → M1
Target Milestone: M1 → Future
this is awful. i hit it while testing my nubus custom builds. 
Keywords: helpwanted
Target Milestone: Future → ---
Blocks: 54975
Mozilla CFM build is dead; should this bug go with it?
Keywords: qawanted
CFM is dead.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.