Get Mail does not automatically put email in the Inbox folder

RESOLVED FIXED

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Bryan W. Headley, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

I have several mail filters set up, that moves email into sub-folders of Inbox.
When I do a Get Messages, mail is read from the Pop3 server, and email that
matches regexp's in the filters are moved to their associated sub-folders. Mail
that DOESN'T match any filters, which should go to 'Inbox', do not. Given that
my email account is called 'bwheadley@earthlink.net', I'll see
'bwheadley@earthlink.net (8)' (assuming there are 8 messages which should have
gone to Inbox). To get these messages to appear, I have to completely exit all
Mozilla windows, re-run, and do a Get Messages. The messages appear in the Inbox
folder.

Reproducible: Always

Steps to Reproduce:
1.Nothing Special
2.Get Msgs
3.Note that some messages don't appear in Inbox.
4.Exit Mozilla
5.Restart Moz, do another Get Msgs
6.Messages appear

Actual Results:  
Email appears for the Inbox

Expected Results:  
One Get Msgs is all that was needed. Shouldn't have to exit Moz, either. New
aberrant behavior in 1.3.a.

I have a "junk" filter, which moves junk email to a sub-folder called 'junk'.

I'm going to have to rate the severity major because the solution/work-around
isn't immediately obvious to everyone. It looks like it munged the incoming email.
Reporter, Could you please retest this with a more current version either the
latest (stable) milestone or a recent nightly build ?

(Reporter)

Comment 2

14 years ago
Has since been repaired. Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031107

Resolving it per comment 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.