Double quoted addresses look different in news and mail

RESOLVED WORKSFORME

Status

MailNews Core
Composition
P3
normal
RESOLVED WORKSFORME
19 years ago
8 years ago

People

(Reporter: Phil Peterson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Rich, your recent news post had the from header:

From: Rich Pizzarro (News Post) <rhp@netscape.com>

which isn't legal by RFC 822 rules. It should be:

From: "Rich Pizzarro (News Post)" <rhp@netscape.com>

I know we have code for this lying around, but maybe it's not getting called?

Comment 1

19 years ago
adding seth to this because I think he recently was working with the MAIL FROM
part of this in SMTP

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Comment 2

19 years ago
Any idea what the old call was to make sure these addresses are valid?

- rhp
(Reporter)

Comment 3

19 years ago
See msg_make_full_address() in ns\lib\libmsg\addrutil.cpp
I have a fix for that in my tree. Fell free to reassign this bug to me.
(Reporter)

Updated

19 years ago
Assignee: rhp → ducarroz
Status: ASSIGNED → NEW

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M13 → M12
Fixed and checed in. Review by jefft

Updated

19 years ago
Status: RESOLVED → REOPENED
QA Contact: lchiang → nbaca

Updated

19 years ago
Resolution: FIXED → ---

Comment 6

19 years ago
Build 1999121308M12: NT4, Linux/Rehat 6.0, Mac 8.5.1
Reopen

Problem: 5.0 does not display the quotes in the From: field when special
characters are present in the `Your Name` field in the Identities panel.

Steps to reproduce:
1. In the Identity panel change the `Your Name` field to include special
characters such as parenthesis (`Ninoschka Baca (News Post)`)
2. Create and send a news message using 4.7
3. View the message in 4.7
4. View the message in 5.0
5. Create and send a news message using 5.0
6. View the message in 4.7
7. View the message in 5.0


Actual Reqults: Notice that both messages do not display the quotes in 5.0 but
do display them in 4.7.

Expected Results: 5.0 should display the quotes when special characters are
present - "Ninoschka Baca (News Post)" <nbaca@netscape.com>

Updated

19 years ago
Status: REOPENED → ASSIGNED
Right, when we display a message, we unquoted the recipients email adresses,
just nicer. I don't think so is a problem. Rich, what do you thing?

Updated

19 years ago
Target Milestone: M12 → M13
The only issue I see with unquoting recipients is that if somebody while writing
an email to one of those recipient write manually exactly what he/she see, it
will not work!
(Reporter)

Comment 9

19 years ago
JF, in that case, we're supposed to re-apply all the required quoting, which is
what the old products do.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
I have a fix for that (see attachment) but now that mscott has landed the new message display which doesn't use
anymore the XUL emitter, the patch as no sence. Fortunally, the new message display show the email address as it
has been received therefore it's already quoted when needed. Therefore I mark this bug as fixed.

Comment 12

19 years ago
Build 2000012009M13: NT4
Haven't checked Mac or Linux yet.
Reopening.

1. News Identity using special characters (i.e. parenthesis)
a. Quotes appear in the "From:" field when reading news messages, which is good:
"qatest32 (news post)" <qatest32@netscape.com>.
b. If the same news message is sent to an email account, when the message is 
displayed in the mail account then the from field strips the area in parenthesis 
and states: qatest32<qatest32@netscape.com>
- 4.7's behavior is different. It displays: qatest32@netscape.com (qatest32). - 
How should this work? Why does it strip the "(news post)" portion? I would have 
expected: "qatest32 (news post)" <qatest32@netscape.com>.

c. Select "Reply" and the area in parenthesis is removed in the "From:" field, 
This doesn't seem right:
qatest32<qatest32@netscape.com>

2. Mail Identity using special characters (i.e. parenthesis)
If I place special characters in the "Your Name" field for my Mail identity then 
I wouldn't expect anything to be stripped when sending or viewing the message 
but the current behavior strips it anytime it is viewed in a mail message. Would 
this be a seperate issue/bug?


Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---
But can send the message despite this problem? if yes, I will move it to M14.

Comment 14

19 years ago
Build 2000012008M13: Linux and Mac behavie the same way.
Yes, the message gets sent without a problem. 
M14
Status: REOPENED → ASSIGNED
oops, now it's M14
Target Milestone: M13 → M14
(Reporter)

Comment 17

19 years ago
Since we do the double quoting now, I think that's enough for B1. The remaining
part of this bug (quoted address looking different in mail than in news) can
wait for post B1.
Summary: RFC 822 special characters must be quoted → Double quoted addresses look different in news and mail
Target Milestone: M14 → M16

Comment 18

18 years ago
Not beta2 stopper.  Marking M18.

Comment 19

18 years ago
Oops.  Really marking M18 now...
Target Milestone: M16 → M18

Comment 20

18 years ago
Moving to future milestone. If this causes a serious end user or interop 
problem, feel free to add that information to the bug so we can reconsider.
Target Milestone: M18 → Future

Updated

18 years ago
Keywords: mail3

Comment 21

18 years ago
Adding mail3 keyword.

Comment 22

18 years ago
reassigning bug to self
Assignee: ducarroz → varada
Status: ASSIGNED → NEW

Comment 23

18 years ago
marking nbeta1-
Keywords: nsbeta1-

Comment 24

18 years ago
Accepting bugs.
Status: NEW → ASSIGNED
taking all of varada's bugs.
Assignee: varada → sspitzer
Status: ASSIGNED → NEW
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: nbaca → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
As near as I can tell from the STR, this is WFM.
Status: NEW → RESOLVED
Last Resolved: 19 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.