GameSpot Complete does not support cookie handling of "Netscape" (i.e. Gecko based) browsers

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: d_yerrick, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021219
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021219

GameSpot Complete, the part of GameSpot.com available only by
subscription (4.95 USD per month), gives an error message when
the user attempts to sign up with Mozilla.

Reproducible: Always

Steps to Reproduce:
1. Go to GameSpot.
2. Click a link.
3. Find that the content to which the link points requires a subscription.

Actual Results:  
alert("Netscape Navigator is not currently supported by GameSpot Complete. We
are working to remedy this situation, and we apologize for any inconvenience
it may cause. In the meantime, please sign up using a different browser.");

After the user presses OK, the form loads.  I have not tried clicking
Submit because I do not wish to purchase a GameSpot Complete subscription
at this time.

Expected Results:  
GameSpot Complete doesn't complain about the presence of Mozilla.

As the alert box said, GameSpot claims to be working on the problem.
Possible actual scenarios:
1. The developers have encountered problems bringing GameSpot
   Complete up to web standards.
2. The developers have forgotten about the project to bring GameSpot
   Complete up to web standards.
3. GameSpot is lying.

Updated

16 years ago
Keywords: evang500

Comment 1

16 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us

Comment 2

15 years ago
This is no longer any problem. Reporter can you verify?
(Reporter)

Comment 3

15 years ago
The Basic signup form does not present a warning alert, but I still
get a warning alert when viewing the Complete signup form.
( http://www.gamespot.com/gamespot/misc/complete/signup2.html )
The text of the warning has changed to the following:

  Due to Netscape Navigator's handling of cookies, Netscape users may have
  difficulty logging in or out of GameSpot Complete. We recommend that you
  use Internet Explorer when logging in and out of GameSpot Complete.

I am using a month-old Mozilla build for Windows; is this the problem?
(Reporter)

Comment 4

15 years ago
I get the same warning on build 20030818.
Summary: GameSpot Complete does not support "Netscape" (i.e. Gecko based) browsers → GameSpot Complete does not support cookie handling of "Netscape" (i.e. Gecko based) browsers

Comment 5

15 years ago
I dont get any warning on the page mentioned in comment 3, can anyone verify?
(Reporter)

Comment 6

15 years ago
No more warning (Mozilla build 2003120808, Windows 2000).  Confirmation from
users of Linux or Mac OS X?

Comment 7

15 years ago
Resolving as WFM based on comments.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.