Query charset searching on dmoz.org does not match with which dmoz.org expects

RESOLVED FIXED

Status

SeaMonkey
Search
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: opmolf, Assigned: philor)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-HN; rv:1.3b) Gecko/20021226
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-HN; rv:1.3b) Gecko/20021226

details below

Reproducible: Always

Steps to Reproduce:
1. Set dmoz.org as the search engine: Edit - Preferences... - Navigator -
Internet Search - Search using: dmoz.org
2. Search a string with characters outside the ASCII, for example "mozillá"

Actual Results:  
The query generated by Mozilla is:
http://search.dmoz.org/cgi-bin/search?search=mozill%E1

dmoz.org search for "mozill?"

Expected Results:  
(for example) Generate the query:
http://search.dmoz.org/cgi-bin/search?search=mozill%C3%A1
(which is generated when writing "mozillá" directly on dmoz.org)

It is interesting to see that searching for "mózillá" works properly (two errors
are no error, binary logic ;)
http://search.dmoz.org/cgi-bin/search?search=m%F3zill%E1

But, in general, dmoz.org uses UTF-8 (I think):
http://search.dmoz.org/cgi-bin/search?search=m%C3%B3zill%C3%A1

So, I tried to read those search plugins in "searchplugins" folder of Mozilla
and decided to add a line on "dmoz.src" SEARCH tag: "queryCharset="utf-8""
(changes on dmoz.src added as attachment)

I really don't know the specification of these SRC files but it turns out that
now it works as dmoz.org expects.

Finally, finding similar bugs I have found the 62409 "Local Charsets are not
supported in SearchPlugins", but I think they are not the same although similar.
(Reporter)

Comment 1

16 years ago
Created attachment 110151 [details]
Changes on /searchplugins/dmoz.src
(Reporter)

Comment 2

16 years ago
See bug "Missing  queryCharset in google.src",
http://bugzilla.mozilla.org/show_bug.cgi?id=180674.

Comment 3

14 years ago
see also bug 62409
Assignee: samir_bugzilla → asa

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

13 years ago
Created attachment 197434 [details] [diff] [review]
plugin patch

queryCharset for sending, charset for interpreting, tabs are evil
Attachment #110151 - Attachment is obsolete: true
Attachment #197434 - Flags: superreview?(alecf)
Attachment #197434 - Flags: review?(timeless)
(Assignee)

Comment 5

13 years ago
Created attachment 197435 [details] [diff] [review]
-w of above
(Assignee)

Comment 6

13 years ago
Created attachment 197436 [details] [diff] [review]
website patch

And since it updates from http://www.mozilla.org/projects/search/dmoz.src that
needs to be patched at the same time.
Assignee: asa → bugzilla
Status: NEW → ASSIGNED

Updated

13 years ago
Attachment #197434 - Flags: superreview?(dmose)
Attachment #197434 - Flags: superreview?(alecf)
Attachment #197434 - Flags: review?(timeless)
Attachment #197434 - Flags: review+

Comment 7

13 years ago
Comment on attachment 197434 [details] [diff] [review]
plugin patch

sr=dmose
Attachment #197434 - Flags: superreview?(dmose) → superreview+
(Assignee)

Updated

13 years ago
Whiteboard: [checkin needed]
(Assignee)

Comment 8

13 years ago
Fixed, trunk and web.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.