Closed Bug 186832 Opened 18 years ago Closed 16 years ago

[JA IME]No red underline with un-commit mode input character with Japanese encoding

Categories

(Core :: Internationalization, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: amyy, Assigned: tetsuroy)

Details

(Keywords: intl, regression)

Build: 12-26 trunk build on WinXP and WinME.

Steps to reproduce:
1. Go to some pages that has Japanese encoding. e.g.:
http://www.yomiuri.co.jp, http://www.asahi.com, http://www.yahoo.co.jp
or change the US pages (e.g. http://www.yahoo.com) to JA encoding.
2. Enable Japanese IME, and start type.

Actual result:
The un-commit hiragana will display fine but without read underline.

Expected result:
There should be a red underline associated with the un-commit hiragana.

If I go to some US encoding page, e.g. http://www.yahoo.com, or change the
Japanese page to western encoding, then the underline will show-up.

Note:
Not reproduce on N7.01, probably regression by fix of bug 98434.
Roy, do you still own Win32 IME?
Assignee: smontagu → yokoyama
this looks like while ASCII mixed with Japanese, the baseline got push down some
pixel and outside the box. maybe we should solve this problem by not using
underline for ime, but use different highlight color. 
I cannot reproduce with 2004111004/WinXP.
WFM?
-> WFM
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.