Open Bug 1868374 Opened 3 months ago Updated 2 months ago

Ship transform-box: content-box | stroke-box

Categories

(Core :: CSS Parsing and Computation, task)

task

Tracking

()

REOPENED
Tracking Status
relnote-firefox --- ?

People

(Reporter: boris, Assigned: boris)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

(Keywords: dev-doc-needed)

Attachments

(1 file)

No description provided.

This is for interop-2023 on the release channel. It looks like other browsers have shipped this feature, per wpt.fyi on stable.

Also, I expect https://github.com/w3c/csswg-drafts/issues/9640 doesn't block this shipment. Just need to be clear about what is the expected behavior for this cyclical dependency.

Severity: -- → S3
Summary: Ship transform-box: content-box | "stroke-box" → Ship transform-box: content-box | stroke-box
Keywords: dev-doc-needed
Assignee: nobody → boris.chiou
Status: NEW → ASSIGNED
Pushed by bchiou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3152110c63b5
Ship transform-box: content-box | stroke-box. r=emilio
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 122 Branch

:emilio, sorry for the ping Boris has a PTO until Jan 15 status.
Could you consider nominating this for a release note?

Flags: needinfo?(emilio)

Release Note Request (optional, but appreciated)
[Why is this notable]: Extension to the transform-box feature
[Affects Firefox for Android]: yes
[Suggested wording]: Support for the content-box and stroke-box of the transform-box CSS property.
[Links (documentation, blog post, etc)]: https://groups.google.com/a/mozilla.org/g/dev-platform/c/vAT8QMrodq8?pli=1 or this bug, probably?

relnote-firefox: --- → ?
Flags: needinfo?(emilio)

Thanks, added to the Fx122 nightly release notes, please allow 30 minutes for the site to update.
Keeping the relnote-firefox flag as ? to keep it on the radar for inclusion in the final Fx122 release notes

Added needinfo on dholbert as a reminder to discuss backing this out for the moment.

Flags: needinfo?(dholbert)
Regressions: 1870200

Yeah, backing out (i.e. leaving this preffed on for Nightly but not release) makes sense to me, I think, until we can come up with a solution for bug 1870200. Though I'm curious for emilio's thoughts too.

Given we're in soft freeze now, and and there aren't signals that users are tripping over bug 1870200 right now (i.e. this isn't going to cause immediate trouble on Beta), I think we can take a look at backing out (or landing + uplifting a fix if we can think of one) next week after emilio's gotten a chance to weigh in.

Flags: needinfo?(dholbert) → needinfo?(emilio)

Chatted with Emilio on slack, and he agrees we should hold off on letting this ride the trains for now. I'll ask for the pref-unguarding patch here to be backed out.

Flags: needinfo?(emilio)

Donal, would you mind undoing the release-note inclusion in comment 8?

(I think that was just adding it to Nightly release notes -- it actually doesn't make too much sense for Nightly release notes anyway, since this has been supported on Nightly since August via https://hg.mozilla.org/mozilla-central/rev/473ebe5ec7aa4f1c5da45ed580fb56258737a210#l9.15 . The only change in this bug here was that we were removing the "Nightly-only" restriction. But we're now reimposing that restriction via backout, until we've addressed bug 1870200.)

Flags: needinfo?(dmeehan)

Backed out as requested because it is not yet ready for shipping to release.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 122 Branch → ---

Release note from comment 8 removed

Flags: needinfo?(dmeehan)
Depends on: 1870200
No longer regressions: 1870200
You need to log in before you can comment on or make changes to this bug.