fixed background image for #acctCentralGrid makes mozilla crash

RESOLVED DUPLICATE of bug 186752

Status

()

Core
CSS Parsing and Computation
--
critical
RESOLVED DUPLICATE of bug 186752
15 years ago
15 years ago

People

(Reporter: pascalc, Assigned: dbaron)

Tracking

({crash, stackwanted})

Trunk
x86
Windows XP
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB15513548W)

(Reporter)

Description

15 years ago
Build 2002122608 WinXP

Steps to reproduce the bug :

In your profile useChrome.css put the following lines :

#acctCentralGrid {
  background-color: #E3E3E1 !important;
  background-image : url(alyssa_milano_035.jpg);
  background-attachment : fixed;
  background-position : right;
  background-repeat : no-repeat; 
}

Expected result : a nice fixed picture of alyssa milano as a background image in
the mailnews message center pane.

actual result : immediate crash on opening Mail

I've had this CSS rule for MAil for more than a year without any problem. I
think that the last buid that didn't make crash Mozilla was on the 22nd of december.

Talkback ID : TB15513548W

Updated

15 years ago
Keywords: stackwanted
Whiteboard: TB15513548W
(Assignee)

Comment 1

15 years ago
duplicate of bug 186752?
nsCSSRendering::PaintBackgroundWithSC
[c:/builds/seamonkey/mozilla/layout/html/style/src/nsCSSRendering.cpp, line 2905]
nsCSSRendering::PaintBackground
[c:/builds/seamonkey/mozilla/layout/html/style/src/nsCSSRendering.cpp, line 2660]
nsFrame::PaintSelf
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsFrame.cpp, line 981]
nsBoxFrame::Paint
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsBoxFrame.cpp, line 1473]
PresShell::Paint
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 5811]
nsView::Paint [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 278]
nsViewManager::RenderDisplayListElement
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1233]
nsViewManager::RenderViews
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1182]
nsViewManager::Refresh [c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp,
line 768]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1785]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1120]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1142]
nsWindow::OnPaint [c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp,
line 5175]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3873]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1404]
USER32.dll + 0x27ad7 (0x77d37ad7)
USER32.dll + 0x2ccd4 (0x77d3ccd4)
USER32.dll + 0x45bd (0x77d145bd)
USER32.dll + 0x47d4 (0x77d147d4)
ntdll.dll + 0x64da6 (0x77fa4da6)
USER32.dll + 0x95d5 (0x77d195d5)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1559]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1907]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1927]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e614c7) 

*** This bug has been marked as a duplicate of 186752 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.