The fruit commity [http://www.fruit.org.il] distorted display

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
16 years ago
4 years ago

People

(Reporter: xslf, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

the national  fruit commity web site blocks mozilla based browsers, and
redirects them to a pages telling them to download explorer 4 or above.

From the code of the main page:

<script language="javascript">
<!--
outStr = '';
myBrowser = navigator.appVersion;
browser = navigator.appName;

// get rid of all 2.0 and 3.0 browsers
if ((myBrowser.indexOf("3") == 0) || (myBrowser.indexOf("2") == 0)) {
	location.href = "no_flash.html";
}

// person has N4.04 (JS dll bug)
if ((browser.indexOf("Netscape") != -1) && (myBrowser.indexOf("4.04") == 0)) {
	location.href = "no_net.html";
}


// Attributes Detector Script. (c) 1999 ModemMediaPoppeTyson, LP
// Check for the following client capabilities:
// - Flash (via Netscape plugin)

function detectPlugin(plugType,plugName) {
	// detectPlugin Version 2.2
	// (c)1999 MM.PT
			//alert('hi');//
	retStr = "no";
	browser = navigator.appName;
	version = (navigator.appVersion + "3").charAt(0);
	
	if ((browser.indexOf("Netscape") != -1) && version >= 3) {
			 	//IF IT'S A NETSCAPE BROWSER A WORNING!!!!
				location.href = "no_net.html";
		mimeOK = 0;
		pluginOK = 0;
		for (i = 0; i < navigator.mimeTypes.length; i++) {
			mimetype = navigator.mimeTypes[i];
			//alert('hi');
			if (mimetype.type == plugType) {
				mimeOK = 1;
			}
		}
	
		for (i = 0; i < navigator.plugins.length; i++) {
			plugin = navigator.plugins[i];
			if (plugin.description.indexOf(plugName) != -1) {
				pluginOK = 1;
			}
		}
	
		if (mimeOK == 1 && pluginOK == 1) {
			retStr = "yes";
		}
	}
	return(retStr);
}

// check for Flash plugin

hasFlash = detectPlugin("application/x-shockwave-flash","Shockwave Flash 3");

if (hasFlash == "no") {

   hasFlash = detectPlugin("application/x-shockwave-flash","Shockwave Flash 4");
}
//-->

and the page users are directed to:
http://www.fruit.org.il/no_net.html

Reproducible: Always

Steps to Reproduce:
1. Go to site with a mozilla based browser


Actual Results:  
user is blocked and re-directed

Expected Results:  
get in
(Reporter)

Comment 1

16 years ago
The only way to contact them is via this web form:
http://www.fruit.org.il/info.asp?file=mashov
which is blocked for mozilla based browsers, and gave me JavaScript errors in ie6.
Whiteboard: [deny]
(Reporter)

Updated

16 years ago
Summary: The fruit commity [http://www.fruit.org.il] clocks mozilla based browsers → The fruit commity [http://www.fruit.org.il] blocks mozilla based browsers

Comment 2

16 years ago
tech evang june 2003 reorg
Assignee: momoi → hebrew
Component: Middle Eastern → Hebrew
QA Contact: xslf → hebrew
(Reporter)

Comment 3

16 years ago
Can someone who has access to ie please contact them? I have no way of
contacting them, as I do not have access to msie anymore. thanks!

Comment 4

16 years ago
i tried to unleash the tech evangelizm letter at them, with IE6, but it didn't
work :o the send button did nothing.

Comment 5

16 years ago
on the other hand, i found their phone (i think) at the phone directory
<http://www.144.bezek.com/>: 03-5632929, fax: 03-5614672, location: 119
HaHashmonaim st. Tel-Aviv-Jaffa.

Comment 6

12 years ago
the site no longer blocks mozilla, but some pages have distorted dislpay, or just don't work (e.g. scrolling)

i sent them a message through the feedback page (with IE7), and got this in response:
Server object error 'ASP 0177 : 800401f3' 

Server.CreateObject Failed 

/sendMail.asp, line 60 

800401f3 

doesn't look good :/

Comment 7

11 years ago
Tsahi: Have you contacted them?
Summary: The fruit commity [http://www.fruit.org.il] blocks mozilla based browsers → The fruit commity [http://www.fruit.org.il] distorted display
Whiteboard: [deny]

Comment 8

11 years ago
i tried to send them a message again now, and received the same error i reported at comment 6. maybe a phone call is the best choice.

Comment 9

10 years ago
The site seems half-broken even from MSIE, I think this bug should be closed.

Comment 10

10 years ago
the site is certainly riddled with internal errors connecting to it's database. i don't know if its owners care about it at all. for the time being, i can't see a page that doesn't work with mozilla, simply because many pages just don't work. i think we can close, and reopen, or open a new bug, when the site is fixed, if it still has errors.

Comment 11

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.