Browser crashes when I want to close it while several Tabs of the page are still opened

RESOLVED DUPLICATE of bug 156940

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 156940
15 years ago
13 years ago

People

(Reporter: Oliver Putz, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021225
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021225

When I enter the URL www.prolinux.de in the Status Bar and open some Tabs on
this site and close the Browser afterwards the Browser crashes.

The Problem also occurs on several other pages such as:

www.planetquake.de
www.quake.de

Reproducible: Always

Steps to Reproduce:
1.Enter www.prolinux.de in the status bar (Problem doesn't occur when you
bootmark the page and just open the bootmark)
2.Open several Tabs by middle Mouse click
3.Close the whole page (Browser)

Actual Results:  
The Mozilla.exe crashes.

Expected Results:  
Mozilla should have been closed with all its Tabs without crashing

TB15524975Y
TB15524979E
TB15524981W
TB15524984E
TB15524986Q
TB15524988G

Updated

15 years ago
Blocks: 185584
Keywords: crash, stackwanted
Whiteboard: TB15524975Y

Comment 1

15 years ago
I'm having lots of troubles with tabs myself (build 2002122608 on Mac OS 9.2.2).
Most crashes happen when I close a tab or a window with tabs inside. I haven't
seen a crash with a window (without tabs) in a long time, so it's related to the
tabs themselves.

For instance :
TB15526459G
TB15526385Y

I've tried to create a new profile, disabling prefetching, etc ... all without
result. I'm 100% sure that it has been reported before, but it's very difficult
to see, since we can't compare stacktraces ourselves.

Comment 2

15 years ago
Dupe of bug 156940 or bug 178688 maybe?

Updated

15 years ago
No longer blocks: 185584

Comment 3

15 years ago
this seems to be the same bu as in  168013
http://bugzilla.mozilla.org/show_bug.cgi?id=168013

Over there at bug 168013 they have a patch - is it possible to apply the patch
without commpiling mozilla ?

works with several uri. just open a few tabs and close one that is still loading.
0x003b009c
nsXULTooltipListener::DestroyTooltip() [nsXULTooltipListener.cpp, line 652]
nsXULTooltipListener::HideTooltip() [nsXULTooltipListener.cpp, line 519]
nsXULTooltipListener::sAutoHideCallback() [nsXULTooltipListener.cpp, line 697]
nsTimerImpl::Fire() [nsTimerImpl.cpp, line 383]
handleTimerEvent() [nsTimerImpl.cpp, line 448]
PL_HandleEvent() [plevent.c, line 663]
PL_ProcessPendingEvents() [plevent.c, line 593]
nsEventQueueImpl::ProcessPendingEvents() [nsEventQueue.cpp, line 388]
nsMacNSPREventQueueHandler::ProcessPLEventQueue() [nsToolkit.cpp, line 182]
nsMacNSPREventQueueHandler::RepeatAction() [nsToolkit.cpp, line 147]
Repeater::DoRepeaters() [nsRepeater.cpp, line 136]
nsMacMessagePump::DispatchEvent() [nsMacMessagePump.cpp, line 501]
nsMacMessagePump::DoMessagePump() [nsMacMessagePump.cpp, line 313]
nsAppShell::Run() [nsAppShell.cpp, line 120]
nsAppShellService::Run() [nsAppShellService.cpp, line 471]
main1() [nsAppRunner.cpp, line 1543]
main() [nsAppRunner.cpp, line 1904]
.__start 
Keywords: stackwanted
Whiteboard: TB15524975Y

Updated

15 years ago
Keywords: stackwanted

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 184363 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
The originally reported crash stacks (on win32) are for bug 156940 
[@ morkRowObject::CloseRowObject]

The stacks in comment #1 (for Mac) are for bug 184363 
[@ nsXULTooltipListener::DestroyTooltip]

Let's try not to mix-and-match, mm-kay?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 156940 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.