Closed Bug 1868977 Opened 4 months ago Closed 4 months ago

Perma /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Element-setHTMLUnsafe-04.html | setHTMLUnsafe should leave the removed children alone. - p.setHTMLUnsafe is not a function when Gecko 122 merges to Beta on 2023-12-18

Categories

(Core :: DOM: Core & HTML, defect)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr115 --- unaffected
firefox120 --- unaffected
firefox121 --- unaffected
firefox122 + verified

People

(Reporter: SerbanS, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Central-as-beta-simulation

How to run these simulations

Failure log

[task 2023-12-08T12:21:53.459Z] 12:21:53     INFO - TEST-OK | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Document-parseHTMLUnsafe-url.html | took 1028ms
[task 2023-12-08T12:21:53.460Z] 12:21:53     INFO - TEST-START | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Document-parseHTMLUnsafe.html
[task 2023-12-08T12:21:53.468Z] 12:21:53     INFO - Closing window cc8a0266-f0d5-487a-8bcc-bdd237b32ffd
[task 2023-12-08T12:21:54.217Z] 12:21:54     INFO - TEST-ERROR | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Document-parseHTMLUnsafe.html | took 759ms
[task 2023-12-08T12:21:54.218Z] 12:21:54     INFO - TEST-START | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Element-setHTMLUnsafe-04.html
[task 2023-12-08T12:21:54.243Z] 12:21:54     INFO - Closing window af98800e-4ce0-4bb9-928f-1dab978423ad
[task 2023-12-08T12:21:55.204Z] 12:21:55     INFO - 
[task 2023-12-08T12:21:55.205Z] 12:21:55     INFO - TEST-UNEXPECTED-FAIL | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Element-setHTMLUnsafe-04.html | setHTMLUnsafe should leave the removed children alone. - p.setHTMLUnsafe is not a function
[task 2023-12-08T12:21:55.205Z] 12:21:55     INFO - @http://web-platform.test:8000/html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Element-setHTMLUnsafe-04.html:21:5
[task 2023-12-08T12:21:55.205Z] 12:21:55     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2599:25
[task 2023-12-08T12:21:55.205Z] 12:21:55     INFO - test@http://web-platform.test:8000/resources/testharness.js:628:30
[task 2023-12-08T12:21:55.205Z] 12:21:55     INFO - @http://web-platform.test:8000/html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Element-setHTMLUnsafe-04.html:14:5
[task 2023-12-08T12:21:55.205Z] 12:21:55     INFO - TEST-OK | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/Element-setHTMLUnsafe-04.html | took 987ms
[task 2023-12-08T12:21:55.220Z] 12:21:55     INFO - PID 8697 | 1702038115219	Marionette	INFO	Stopped listening on port 48162
[task 2023-12-08T12:22:01.224Z] 12:22:01     INFO - Browser exited with return code 0
[task 2023-12-08T12:22:01.227Z] 12:22:01     INFO - Closing logging queue
[task 2023-12-08T12:22:01.227Z] 12:22:01     INFO - queue closed
[task 2023-12-08T12:22:01.239Z] 12:22:01     INFO - INFO | runtests.py | TSan using symbolizer at /builds/worker/workspace/build/application/firefox/llvm-symbolizer
[task 2023-12-08T12:22:01.239Z] 12:22:01     INFO - Application command: /builds/worker/workspace/build/application/firefox/firefox --marionette about:blank -profile /tmp/tmp2tgxoake
[task 2023-12-08T12:22:01.249Z] 12:22:01     INFO - PID 9057 | ATTENTION: default value of option mesa_glthread overridden by environment.
[task 2023-12-08T12:22:01.250Z] 12:22:01     INFO - PID 9057 | 1702038019245	Marionette	INFO	Marionette enabled
[task 2023-12-08T12:22:01.250Z] 12:22:01     INFO - PID 9057 | ATTENTION: default value of option mesa_glthread overridden by environment.
[task 2023-12-08T12:22:01.251Z] 12:22:01     INFO - PID 9057 | 1702038020399	RemoteAgent	WARN	PollPromise timed out after 5000 ms
[task 2023-12-08T12:22:01.252Z] 12:22:01     INFO - PID 9057 | 1702038020410	Marionette	INFO	Listening on port 47364
[task 2023-12-08T12:22:01.253Z] 12:22:01     INFO - PID 9057 | console.error: ({})
[task 2023-12-08T12:22:01.253Z] 12:22:01     INFO - Starting runner
[task 2023-12-08T12:22:02.758Z] 12:22:02     INFO - TEST-START | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/setHTMLUnsafe-xml.html
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - 
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - TEST-UNEXPECTED-FAIL | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/setHTMLUnsafe-xml.html | setHTMLUnsafe should still parse HTML even in XML documents. - xmlDoc.documentElement.setHTMLUnsafe is not a function
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - @http://web-platform.test:8000/html/webappapis/dynamic-markup-insertion/html-unsafe-methods/setHTMLUnsafe-xml.html:12:26
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:2599:25
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - test@http://web-platform.test:8000/resources/testharness.js:628:30
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - @http://web-platform.test:8000/html/webappapis/dynamic-markup-insertion/html-unsafe-methods/setHTMLUnsafe-xml.html:8:5
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - .
[task 2023-12-08T12:22:04.182Z] 12:22:04     INFO - TEST-OK | /html/webappapis/dynamic-markup-insertion/html-unsafe-methods/setHTMLUnsafe-xml.html | took 1427ms
Flags: needinfo?(avandolder)

Also, we have these wpt failures.

  • Failure Log
  • Failure line: TEST-UNEXPECTED-FAIL | /html/dom/idlharness.https.html?exclude=(Document|Window|HTML.*) | Element interface: document.createElement("noscript") must inherit property "setHTMLUnsafe(DOMString)" with the proper type - assert_inherits: property "setHTMLUnsafe" not found in prototype chain

  • these wpt failures.

  • Failure Log

  • Failure line: TEST-UNEXPECTED-FAIL | /html/dom/idlharness.https.html?include=(Document|Window) | Document interface: operation parseHTMLUnsafe(DOMString) - assert_own_property: interface object missing static operation expected property "parseHTMLUnsafe" missing

Flags: needinfo?(avandolder)
See Also: → 1869003

:avandolder, since you are the author of the regressor, bug 1712140, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(avandolder)

:avandolder for tracking purposes, is the patch attached to Bug 1869003 expected to also address this perma failure?

Ah, yes it is.

Flags: needinfo?(avandolder)

Verified in today's beta simulation. The patch from Bug 1869003 indeed fixes these perma failures also

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.