Cookie Manager scroll bar looks messed up

VERIFIED DUPLICATE of bug 128496

Status

()

Core
Networking: Cookies
VERIFIED DUPLICATE of bug 128496
15 years ago
13 years ago

People

(Reporter: José Jeria, Assigned: Darin Fisher)

Tracking

({classic, regression})

Trunk
x86
Windows XP
classic, regression
Points:
---
Bug Flags:
blocking1.3 -
blocking1.4a -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021226
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021226

Open the Cookie Manager, Window looks messed up (see screenshot).
If this is not visible resize window horinzontally.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Created attachment 110207 [details]
Screenshot

Comment 2

15 years ago
wfm on Moz 2002121108 and NT4. Using modern theme.
(Reporter)

Comment 3

15 years ago
This is only Classic theme
Summary: Cookie Manager scroll bar looks messed up → [Classic] Cookie Manager scroll bar looks messed up

Updated

15 years ago
Keywords: classic
Summary: [Classic] Cookie Manager scroll bar looks messed up → Cookie Manager scroll bar looks messed up

Comment 4

15 years ago
Bug confirmed - 2002121008/NT4/Classic theme

Comment 5

15 years ago
This bug is already reproducable with 2002121004.
However, it is *not* in 1.2.1 (at least in my own build).

This does not only affect the cookie manager, but also (at least) the image
manager (just make the window smaller).
Password manager behaves as all the managers did before: if the window is too
small, the pane, that contains the active tab content, gets cut by the right
window border because it has some minimum size.

This bug is caused by that plane *not* having any minimum size anymore. So
content (scrollbar etc.) is drawn over/across it.

Comment 6

15 years ago
I think the password manager is only not affected because his tabs have a
minimum size that "push" the right border of the tab-pane to the right out of
the window if it gets too small to display them.

The two other managers I mentioned obviously *used* to have other element(s)
with a minimum size that pushed the tab-pane-border out of the window. Now,
*this* minimum size seems not to be in effect anymore.

Additionally, CookieViewer.xul and SignonViewer.xul both have not been changed
since August, so I'm sure the problem is the change of the behaviour of some XUL
element(s) that previously had the power to set a minimum size of the containing
element, but now do not have such a power anymore.
(Reporter)

Updated

15 years ago
Keywords: regression

Comment 7

15 years ago
This regressed between 12/01 and 12/04 a.m. builds. So, I'd have to figure 
this is related to the changes for bug 172751 "nsITheme support for 2k/nt/95".

(And this is a separate bug, but between 12/10 and 12/11, the scrollbar in 
the tree widget, using the Modern theme, is now painted in native colors, not
with the Modern style. Is that a known bug?)

Assignee: jaggernaut → varga
Component: XP Toolkit/Widgets → XP Toolkit/Widgets: Trees
QA Contact: jrgm → shrir

Comment 8

15 years ago
I can't get it to look exactly like the screenshot, but I do see problems with 
resizing.  Turning off theming fixes the problem.  I think it's a general 
theming bug.  It happens on XP/Luna, and I'm guessing it happens on GTK themes 
too.

The scrollbar issue is bug 185309.

Comment 9

15 years ago
Resize the Cookie/Image manager window vertically for another form of distortion
that is also related to the scrollbar.  I can also see this in the Page Info
window (in the "Forms" tab).
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3a) Gecko/20021212]

Confirmed on W95 and W2K with classic theme: see bug 178353 comment 4.

Updated

15 years ago
Flags: blocking1.4a?
Flags: blocking1.3?

Comment 11

15 years ago
Looks the same for me as well, using the classic theme. Can't use the scrollbar
at all for the Stored Cookies tab or the Cookie Sites.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Updated

15 years ago
Flags: blocking1.3? → blocking1.3-

Updated

15 years ago
Flags: blocking1.4a? → blocking1.4a-

Comment 12

15 years ago
-> cookies
Assignee: varga → darin
Component: XP Toolkit/Widgets: Trees → Cookies
QA Contact: shrir → tever

Comment 13

15 years ago
jose: please verify if you think this is the same bug.

*** This bug has been marked as a duplicate of 128496 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
QA Contact: tever → cookieqa
Resolution: --- → DUPLICATE
(Reporter)

Comment 14

15 years ago
verified dupe.
Status: RESOLVED → VERIFIED

Updated

13 years ago
QA Contact: core.networking.cookies → benc
You need to log in before you can comment on or make changes to this bug.