directory permissions after installation, as root, not properly set

VERIFIED DUPLICATE of bug 163524

Status

VERIFIED DUPLICATE of bug 163524
16 years ago
13 years ago

People

(Reporter: katmandu, Assigned: dveditz)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

When I first installed Mozilla 1.2.1, as root, into /usr/local/mozilla, it
installed correctly and executed correctly as root.
After that, when I logged in as a regular user, I could not run mozilla. I found
that the directory 'components' (/usr/loca/mozilla/components) has wrong
directory permissions, without the executable flag set. After adding the
executable flag, as root, I could run mozilla as a regular user correctly.

Reproducible: Always

Steps to Reproduce:
1.Just install mozilla as root
2.As root, executes mozilla correctly, all works fine...
3.As regular user, it doesn't works...

Actual Results:  
As regular user, when typed the mozilla command, nothing happens, goes back to
shell prompt.

Expected Results:  
The installer should create the directories with proper permissions for both,
root and regular users, run mozilla.

I fixed the problem setting the executable flag of the directory 'components'
after the installation.
How did you install?  Installer?  .tar.gz?  RPM?  .deb?
(Reporter)

Comment 2

16 years ago
I installed from this file:
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.2.1/mozilla-i686-pc-linux-gnu-1.2.1-sea.tar.gz

It's a .tar.gz file with a installer inside! :)
--> installer
Assignee: asa → dveditz
Component: Browser-General → Installer
QA Contact: asa → bugzilla

Comment 4

16 years ago
dupe

*** This bug has been marked as a duplicate of 163524 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v.

Comment 6

16 years ago
[duh! this time truly verifying]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.