Trying to read yahoo-mail results in infinite refresh loop

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Antonio Garcia, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

The browser refreshes in an infinite loop.  From viewing the mail under Mozilla
1.0.1 and 1.1, or Internet Explorer, the browser refreshes the page once. 
However, under Mozilla 1.2.1 and 1.3 it becomes impossible to read mail simply
because the browser reloads the mail page before you can read the mail.

Reproducible: Always

Steps to Reproduce:
1. Log into a yahoo mail account.
2. Click on the Inbox to view new messages.
3. Click on the link to view a specific message

Actual Results:  
Browser beging infinite refresh loop.

Expected Results:  
Display the page and stop.
(Reporter)

Comment 1

15 years ago
Problem can be "worked-around" by enabling Cookie read/modify for JavaScript.

By default, I prefer to turn this off.
The page's JS is designed to go into such a loop if it can't set the cookie (it 
sets the cookie, then tries to read it, and reloads if the cookie is not 
present).  So on this site, your options are to turn off that option or get the 
site to fix their code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.