unable to assign custom wav file to new mail notification



MailNews: Message Display
15 years ago
9 years ago


(Reporter: David M. Cvet, Unassigned)


Firefox Tracking Flags

(Not tracked)




15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

When one customizes the new email notifications, selecting a customized wav file
does not alter the notification sound.  The "preview" button also doesn't pick
up the custom wav file to test it (audio).

Reproducible: Always

Steps to Reproduce:
2.mail & newsgroups
4.select custom wav file for notifications (OK, this works)
5.test preview doesn't work, the custom wav file is not activated when new mail

Actual Results:  
nothing. default new email sound remains enabled.

Expected Results:  
invoke the custom wav file for the arrival of new email


15 years ago
QA Contact: laurel → stephend

Comment 2

15 years ago
David Cvet, have you been able to resolve this bug?  As noted in comment 1, 
there were several potential problems; the issue in bug 169414 still exists.
Also, bug 177280 has been fixed for a while. (perhaps this is a dupe of that?)

Comment 3

15 years ago
This also occurs in Thunderbird 0.4.  You are able to check "Play a Sound" but
the options to select a custom .WAV file are grayed out.  Downgrading to 0.3
fixes the problem.

Comment 4

15 years ago
Re comment #3:
I believe this is off-topic to this bug: the original reporter said that he
could  'select custom wav file for notifications' - comment #3 sais that 'the
options to select a custom .WAV file are grayed out'.

@danny peck:
retest on a current nightly build of Thunderbird, and file a separate bug if
your UI problem is still present.

I cannot reproduce your problem on a week-old Mozilla trunk build on Linux - is
your problem still present? Do you have artsd or esd or any other application
or daemon running that might be blocking the sound device? To get sounds working
(Linux, KDE) I have to use 'artsdsp ./mozilla' to start Mozilla, otherwise artsd
will block the sound device, and mozilla natively doesn't know about arts.

To test, just kill anything that might be accessing the sound device and try again.

Comment 5

15 years ago
*** Bug 228024 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Oops, sorry about the duplicate -- not sure how I missed this one.  In any case,
yes, this bug still exists.  I'm running KDE and made sure to kill all sound
servers (artsd).  I also tried running mozilla under artdsp.  I also tried
running it under esd.  No success in any of these cases.  I got sound working
[outside of mozilla] in all three cases 1) no sound server 2) artsd 3) esd -- so
it's not that my sound is broken!

I've also tried prepending file:///, file:\\\, and lots of other possibilities.

Any ideas on how to debug this?  

Existing summary is misleading.  Someone with permission should change summary to:

mail notification custom .wav file doesn't play [preview button doesn't play it

Comment 7

14 years ago
Still broken in Mozilla 1.6.

Anyone have any ideas on how to debug this?
Product: Browser → Seamonkey

Comment 8

14 years ago
*** This bug has been confirmed by popular vote. ***
Ever confirmed: true


14 years ago
Whiteboard: DUPME → DUPEME

Comment 9

13 years ago
Similar to bug 225219 . Dupe?


13 years ago
Assignee: sspitzer → mail

Comment 10

12 years ago
(In reply to comment #9)
> Similar to bug 225219 . Dupe?
Could be a dupe.  Reporters at 225219 claim it's now WFM with TB 1.5.
David Cvet, is this bug still a problem for you with Seamonkey 1.0 (or TB 1.5, if you've switched)?
Assignee: mail → nobody
QA Contact: stephend → message-display

Comment 11

9 years ago
WFM Ubuntu 8.04 1.1.7 and 2.0.1pre
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.