we process using the sourcenodes ownerdocument

VERIFIED FIXED

Status

()

Core
XSLT
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: sicking, Assigned: sicking)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

We ignore the supplied sourcenode and use its owning document instead. Both for
the main processing, and for processing global variables.

Patch comming up
Created attachment 110269 [details] [diff] [review]
patch to fix
Attachment #110269 - Flags: superreview?(peterv)
Attachment #110269 - Flags: review?(axel)
Comment on attachment 110269 [details] [diff] [review]
patch to fix

please ignore the changes to the output-handler. They are not part of this bug.
Forgot to save before attaching

Comment 3

15 years ago
Would you mind saying a little bit more precisely what's wrong?
Which entry points and whatnot.
And I'd prefer a patch with just the stuff in it that belongs here.
Created attachment 110359 [details] [diff] [review]
patch to fix

The problem exists with all entrypoints in module. The problem is that instead
of processing using the supplied sourcenode, we get it's ownerdocument and run
the transformation using that.

We also process top-level variables using this document-node. To fix this I had
to let the ProcessorState keep an mSourceNode instead of an mSourceDocument.
Attachment #110269 - Attachment is obsolete: true
Attachment #110269 - Flags: superreview?(peterv)
Attachment #110269 - Flags: review?(axel)
Attachment #110359 - Flags: superreview?(peterv)
Attachment #110359 - Flags: review?(axel)
Attachment #110359 - Flags: superreview?(peterv) → superreview+
Hmm, actually, how does this fit with section 5.1 of the XSLT spec? You claim
the "root node" is the node that we get supplied?

http://www.w3.org/TR/xslt#section-Processing-Model
yeah, I think we should support starting the transformation at any node.

We will always start the processing using the document-node (or root-node) when
transforming using a processing-instruction.
Status: NEW → ASSIGNED
Created attachment 112459 [details] [diff] [review]
sync to tip
Attachment #110359 - Attachment is obsolete: true
Attachment #110359 - Flags: review?(axel)
Comment on attachment 112459 [details] [diff] [review]
sync to tip

this is different enough that i think i need a new sr..
Attachment #112459 - Flags: superreview?(peterv)
Attachment #112459 - Flags: review?(axel)

Comment 9

15 years ago
Comment on attachment 112459 [details] [diff] [review]
sync to tip

here you go, r=axel@pike.org
Attachment #112459 - Flags: review?(axel) → review+
Attachment #112459 - Flags: superreview?(peterv) → superreview+
Comment on attachment 112459 [details] [diff] [review]
sync to tip

due to simplicity of the patch it is very lowrisk. It will also only affect
pages using XSLT.
Attachment #112459 - Flags: approval1.3b?

Comment 11

15 years ago
Comment on attachment 112459 [details] [diff] [review]
sync to tip

a=asa (on behalf of drivers) for checkin to 1.3beta.
Attachment #112459 - Flags: approval1.3b? → approval1.3b+
checked in. Thanks for reviews
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
mass verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.