If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

pages do not load when running only wireless on powerbook

VERIFIED DUPLICATE of bug 186981

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 186981
15 years ago
15 years ago

People

(Reporter: Jaroslav Tyman Jr., Assigned: dougt)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021212

I'm running a Powerbook g4 with osX.2.3 and have 2 possible connections to the
internet: the hardwire builtin ethernet or the wireless.  Both connections run
through a linux router and both are configured manually (no dhcp).  

When browsing with the ethernet, everything works great.  When I switch over to
the wireless, many pages don't load.  I can ping the URL's, I can even browse to
the URL in IE, but they are broken in Mozilla 1.2, 1.3a, Chimera, and Netscape 7
(whichever builds are available on the downloads page).

Example:  When loading any pages at google.com under ethernet, the pages load
quickly and correctly.  If I am browsing on the wireless (using the built in
airport card) the pages don't load (unless cached, but then images still don't
load).  I get "Sending request to www.google.com..." in the status bar while it
is hanging.  Eventually the request times out with "The document contains no
data."  

A majority of pages do load in wireless if I haven't visited them while
connected to ethernet (I tried this with random domains off the top of my head,
www.homestarrunner.com for example.  They continue to load in ethernet and
remain working in wireless.

Reproducible: Always

Steps to Reproduce:
1.Browse to a new domain under ethernet.
2.Disconnect ethernet, begin browsing on the wireless network.
3.Visit a page on the domain again.

Actual Results:  
Webpage doesn't load, hangs with "Sending request to www.google.com...". 
Eventually times out with "The document contains no data."

Expected Results:  
Should have resolved the domain regardless of what network device was being used
both at the time of visit and at the initial visit.

This is all happening on a new powerbook with nothing extra added.  Mozilla was
the first thing installed on OSX.2.3.  Network connections work under both
devices (can ping sites that are hanging in mozilla, and can visit said sites in
IE).  Any assistance is appreciated, I really hate going to IE when I need to
disconnect the ethernet.  Cheers!

Comment 1

15 years ago
Duplicate of bug 186981

*** This bug has been marked as a duplicate of 186981 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.