If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

tocDS variable is not declared

VERIFIED FIXED

Status

SeaMonkey
Help Documentation
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Brant Gurganus, Assigned: Ian Oeschger (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021226
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021226

The tocDS variable is no declared.

Reproducible: Always

Steps to Reproduce:
1. Open the Help Viewer
Actual Results:  
Warning: assignment to undeclared variable tocDS
Source File: chrome://help/content/help.js
Line: 245

Expected Results:  
No warning.

Strict warnings must be on.
(Reporter)

Comment 1

15 years ago
Created attachment 110287 [details] [diff] [review]
one-line patch adding var before assignment

I simply replaced an assignment with a declared assignment.  That is
tocDS = something;

became

var tocDS = something;

The length of the patch is due to the fact that my text editor strips trailing
whitespace which is unnecessary and adds size.
(Reporter)

Comment 2

15 years ago
Comment on attachment 110287 [details] [diff] [review]
one-line patch adding var before assignment

I don't have the necessary CVS access to check this in once it is reviewed so
somebody needs to check it in once it is reviewed.
Attachment #110287 - Flags: review?(oeschger)
(Reporter)

Comment 3

15 years ago
I manually added the patched file to my help.jar and ran Mozilla.  No error
appears now openning Help once or more.  I also ran the prechecking tests
without issues.
(Assignee)

Comment 4

15 years ago
Comment on attachment 110287 [details] [diff] [review]
one-line patch adding var before assignment

r=oeschger
Attachment #110287 - Flags: review?(oeschger) → review+
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 5

15 years ago
You gonna put this in yourself?  I don't think I have access to these files for
updating via gila.
(Assignee)

Comment 6

15 years ago
I will try and get this in myself, Brant. I am trying to put some of these small
fixes together so I can check them in all at once.
(Reporter)

Comment 7

15 years ago
Any idea when you will check in these and the other fixes?  I'd like to do some
work and make sure nothing I do has been done or gets duplicated or obsoleted.
(Reporter)

Comment 8

15 years ago
Created attachment 120116 [details] [diff] [review]
one-line patch (cleaner than the other since trailing whitespace wasn't stripped)
Attachment #110287 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Attachment #120116 - Flags: superreview?(alecf)

Comment 9

15 years ago
Comment on attachment 120116 [details] [diff] [review]
one-line patch (cleaner than the other since trailing whitespace wasn't stripped)

sr=alecf
Attachment #120116 - Flags: superreview?(alecf) → superreview+
(Assignee)

Comment 10

15 years ago
FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 11

14 years ago
VERIFIED
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.