Site spawns new windows even though javascript window.open() is disabled

VERIFIED WORKSFORME

Status

SeaMonkey
General
--
critical
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: alanjstr, Assigned: asa)

Tracking

Trunk
x86
Windows 2000
Bug Flags:
blocking1.3b -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20021217

Visiting http://www.committed.to/carbon will cause windows to continuously
pop-up even though scripts are not allowed to open unrequested windows.  The
window it opens seems to be the same.  If the spawning is not stopped by closing
the most recent window fast enough, memory will be consumed and a DOS will occur
(BSOD).  

Reproducible: Always

Steps to Reproduce:
1.  Disable Unrequested Windows in Javascript
2.  Visit the URL


Actual Results:  
Many windows open

Expected Results:  
No new windows should be spawned.

I also run Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20021227 Phoenix/0.5 with Tabbed Browsing Extension turned on.  TBE is set
for Single Window Mode, but new Windows open instead of new tabs.

Originally discussed on http://www.mozillazine.org/forums/viewtopic.php?p=24041

Comment 1

16 years ago
I can confirm this with build 2002-12-28 on Win XP.

If this happens to you, hit ctrl-alt-delete and kill phoenix from there.

Comment 2

16 years ago
i'm having a similar problem. it's not spawning new *windows* for me, bue it
keeps refreshing the current one i have.

this is why:
// Makes "new window" pages open in current window/tab
user_pref("browser.block.target_new_window", true);

i just thought i'd bring that up in case anyone else has this in their user.js
file. it's gotta be the same thing. *tg* i didn't have all the new windows or i
would have taken a bat to my computer or something. lol.

Comment 3

16 years ago
dangit when i copied that from one of my posts i left off my build and os.  my
apologies.

12-27, winme, no ext.

Comment 4

16 years ago
Confirm, WinME, Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.2.1)
Gecko/20021130. Had to use alt-f4 multiple times. It was a shock- never thought
I'd see that behavior in Mozilla. This is obviously not a new problem; I would
bet it's more a "feature" that hasn't been implemented yet. It's critical that
it be implemented due to obvious security, stability, and advertising factors
(people use Mozilla for pop-up blocking in my area), I agree.

Recommendations:
1) Maintain at critical priority
2) Make it blocker for 1.3; it can wait until the milestone comes up but no further
3) Isolate the page code, isolate the offending javascript, and insert a default
preference that blocks this behavior.
4) Long term- If a page, IP address, or file opens more than, say, four windows,
do not allow any further windows to be opened unless the user specifically
allows it. This will help prevent other pop-up related behaviors from becoming
critical.

Comment 5

16 years ago
Confirming on behalf of the previous comments.
committed.to/carbon redirects to http://www.geocities.com/seenu_a76/

I've put the code of the page here:
http://seb.delahaye.net/phoenix/geocities.com-seenu_a76.txt (in text/plain)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.3b?

Comment 6

16 years ago
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3a) Gecko/20030102 Phoenix/0.5

When I attempt to view http://www.committed.to/carbon , Ph goes into an endless
loop, constantly reloading something.  I can get out of it by clicking the
"stop" button.

The following error msgs are repeated several times over in the "javascript
console".

Error: layers[i] has no properties
Source File: http://geocities.yahoo.com/js_source/layers.js
Line: 105

Error: yfnEA is not defined
Source File: http://www.geocities.com/seenu_a76/
Line: 358

Error: syntax error
Source File: http://www.geocities.com/seenu_a76/
Line: 116, Column: 23
Source Code:
c20.imageWidth     =   ** ERROR:java.lang.NullPointerException;

Error: syntax error
Source File: http://www.geocities.com/seenu_a76/
Line: 149, Column: 23
Source Code:
c21.imageWidth     =   ** ERROR:java.lang.NullPointerException;

Error: syntax error
Source File: http://www.geocities.com/seenu_a76/
Line: 182, Column: 23
Source Code:
c22.imageWidth     =   ** ERROR:java.lang.NullPointerException;

Error: syntax error
Source File: http://www.geocities.com/seenu_a76/
Line: 216, Column: 21
Source Code:
c24.imageWidth     = ** ERROR:java.lang.NullPointerException;



Comment 7

16 years ago
I should have noted in comment #6 that I have the following line in my user.js file:

user_pref("browser.block.target_new_window", true);

(Reporter)

Comment 8

16 years ago
Some of that junk is just because Geocities has a Mozilla incompatible banner
ad.  They see "Netscape/Mozilla" and try to give an ad targetted for Netscape 4.x.
(Assignee)

Comment 9

16 years ago
is this any different than bug 126224 ?
(Reporter)

Comment 10

16 years ago
Could this be the culprit "<EMBED SRC="http://www.geocities.com/seenu_a76/"
LOOP=TRUE AUTOSTART=TRUE HIDDEN=TRUE>" ?

Asa, I don't think this is being triggered by an onload event.
(Assignee)

Comment 11

16 years ago
not going to hold the release for this. 
Flags: blocking1.3b? → blocking1.3b-

Comment 12

15 years ago
reporter, does the URL http://www.committed.to/popupframe.php (called indirectly
from the problem site) load pop-up?
(Reporter)

Comment 13

15 years ago
going directly to http://www.committed.to/popupframe.php does not seem to cause
a problem.  The original site still does in my 6/11 Firebird.
(Reporter)

Comment 14

15 years ago
Created attachment 131384 [details]
Page source

Source code for website.
Possible offending lines:
EMBED SRC="http://www.geocities.com/seenu_a76/" LOOP=TRUE AUTOSTART=TRUE
HIDDEN=TRUE

BGSOUND SRC="http://www.geocities.com/seenu_a76/" LOOP=INFINITE

onLoad="window.onresize=new Function('if (navigator.appVersion==\'Netscape\')
history.go(0);'

Comment 15

15 years ago
WFM.  Going to http://www.geocities.com/seenu_a76/ does not spawn new windows.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031007
Firebird/0.7+ (aebrahim)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030911

Comment 16

15 years ago
WFM too, in 1.5 final.  Closing; reopen iff found in a < 3 week old build.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

15 years ago
Popups blocked with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b)
Gecko/20031114 Firebird/0.7+

Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.