Browser sees comment close tag incorrectly and closes comment block prematurely...

RESOLVED INVALID

Status

()

Core
HTML: Parser
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: u81239, Assigned: harishd)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

If a web site has this comment block, it shows this part: '\n"); ?> ^_^.4:48
29-12-2002 -- -- Oh, and LOL, IF THIS APPEARS IN THE SITE CONTENTS, -- you have
just encountered a bug in Mozilla ^_^. -->' in the web site's contents. 

<!--
  -- due to a bug in IE6's 'strict' mode detection it wants !doctype as first
argument
  -- So as for now I left out the (optional) <?xml version="1.0" encoding="UTF-8"?>
  --
  -- also saves me the trouble of writing weird php **** like
  -- <?php echo("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"); ?> ^_^.
  --
  -- Oh, and LOL, <b>IF THIS APPEARS IN THE SITE CONTENTS</b>,
  -- you have just encountered a bug in Mozilla ^_^.
  -->

You can see it on my site (if my computer is on) at http://grauw.xs4all.nl/map/


Greets,

~Grauw

Reproducible: Always

Steps to Reproduce:
1. Create HTML file with specified code in details
2. Open in Mozilla (v1.2.1)
Actual Results:  
'\n"); ?> ^_^.4:48 29-12-2002 -- -- Oh, and LOL, IF THIS APPEARS IN THE SITE
CONTENTS, -- you have just encountered a bug in Mozilla ^_^. -->' appeared in
the site contents

Expected Results:  
it should have closed the comment line after the final --> tag, not one of the
?> tags. Strange thing is that there is another ?> earlier but seemingly it only
has this bug after the second ?>.
The comment end sequence is "--", as is the comment start sequence.  You have a 
whole bunch of comments in there (with the '>' of "?>" coming _outside_ a 
comment, if you count the dashes).

In quirks mode we do the broken comment parsing you seem to expect, but in 
standards mode we parse comments per spec.  The page is rendered in standards 
mode, since you claim it to be XHTML in the doctype (I'm assuming that part, 
since your server is down; but the longwinded comment about leaving out the XML 
decl points in that direction).

Not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Oh, and the first "?>" _is_ inside a comment, if you count the start/end pairs 
correctly...

See http://www.w3.org/TR/html401/intro/sgmltut.html#h-3.2.4
http://www.htmlhelp.com/reference/html40/structure.html#comments 
and especially http://www.htmlhelp.com/reference/wilbur/misc/comment.html
for more information on HTML comment syntax.
You need to log in before you can comment on or make changes to this bug.