Mail crashed when I tried to send message [corrupted XUL.mfl]

VERIFIED DUPLICATE of bug 168516

Status

MailNews Core
Composition
--
major
VERIFIED DUPLICATE of bug 168516
16 years ago
10 years ago

People

(Reporter: Julia, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

I'm using 1.3a and it was working fine til this morning when it crashed while I
was trying to send an email.  I usually use keyboard shortcuts to do this so I
rebooted and tried to do it by clicking with the mouse on the Send button.  Same
result.

Reproducible: Always

Steps to Reproduce:
1.  Hit reply to message.  That works fine.
2.  Composing message works fine.
3.  Any attempt to send message causes prog to crash.

Actual Results:  
Screen froze.  Three-finger salute to reboot.

I've reloaded 1.2

Expected Results:  
Well, golly, it should have sent the email!

BTW, I'm not getting a Talkback window on this.

Comment 1

16 years ago
try delete XUL.mfl in your profile directory (while mozilla is not running.
Quickstart musn't be running at the time either).

If that helps: Which theme were you using when the crash occured?

Comment 2

16 years ago
I have also had this problem.  It happens every time I send mail, i.e., it
doesn't matter whether I reply or start a new message.  I started with 1.3a,
then moved back to 1.2.1, and I have the same problem.  I have tried
uninstalling 1.2.1, deleting my mozilla profile directories, cleaning up the
registry, and then reinstalling, and the problem is still there.  

I am running Windows XP.  It always generates a bug report for me to send to
Microsoft.  I have sent that once, and I intended to include that file in a bug
report to you, but the file is deleted after I finish responding to the XP
prompt window, so I don't know how to get the file to you.

One time that I was having difficulty with sending, it gave me an error message
asking about something in my preferences.  I do not remember what the exact
error message was, but afterwards, Mozilla crashed everytime I tried to open
Preferences until I rebooted my machine.

Comment 3

16 years ago
Build ID: 2002121215

I managed to retrieve the following from the error message that was generated
for Microsoft.  I hope it helps.

szAppName : mozilla.exe     szAppVer : 1.3.0.0     szModName : msgcompo.dll
szModVer : 1.3.0.0     offset : 000255ce     

Comment 4

16 years ago
Kristen French: Please include a Talkback ID of the bug-report sent to Netscape
instead. That is of much more help.

Also: did deleting XUL.mfl help?

Please reply in the bug-report and not by mail.

Comment 5

16 years ago
I would be happy to send a Talkback report, but Talkback is not doing anything.
 I'm pretty sure I got it activated, although I had to do that manually, because
Mozilla did not ever ask me to activate it.  If you have any tips on how I could
test Talkback to be sure that it is active, I'll be happy to try that.

Deleting XUL.mfl had no effect.

I have noticed that if I cancel the send within about 5-10 seconds, Mozilla does
not crash, but asks me to check my mail settings.  I don't think that my mail
settings are incorrect.  I use the same settings with Mozilla 1.0.1 on the linux
side of my machine, and it works fine.  On the XP side, where I see this
problem, I am currently using 1.3a, but 1.2.1 also gives me this problem.

p.s. do you think this bug is a duplicate of 179039?
(Reporter)

Comment 6

16 years ago
Talkback screen did not appear at any time that bug occurred.  Deleting XUL.mfl
fixed the problem.  Thanks for quick response that worked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Summary: Mail crashed when I tried to send message → Mail crashed when I tried to send message [corrupted XUL.mfl]

Comment 7

16 years ago
reopen..
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 168516 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 9

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.