[RFE] : Save state window states accross crashes.

RESOLVED DUPLICATE of bug 36810

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 36810
15 years ago
13 years ago

People

(Reporter: gulfie, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021225 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021225 Chimera/0.6+

It would be amazingly cool If I could get my browser back into aproximately the
same state as when I left it.  Window locations and sizes, as well as history's
would be excielent and sufficent.  Scrolling information would be neat, but not
nessisary. 


It turns out, I'm a horrible mozilla whore.  I use it constantly.  Iv'e
currently got chimera running with 13 windows, and mozilla running with I don't
know how many windows.  I tipicly have 2 to 5 seperate tracks of thougth or work
going on in different sets of windows and they can stay open for days.  Iv'e
basicly been off loading more brain state into mozilla as it has been getting
more stable. 

Needless to say, when ether mozilla crashes, it's time to upgrade or macos X has
a fit, it is like having part of my brain removed.  And it hurts. 

Please help the hurting to stop.  All it would take is a few little files in the
 Library, one for each window, with a set of URLS, a set of geometry
information, and a pointer into the list for the current page.

I like having my brain, I hate it when it leaks out into the bit bucket. 

Reproducible: Always

Steps to Reproduce:
1.work alot
2.work some more
3.crash
Actual Results:  
I cried like a little girl.

Expected Results:  
Saved my brain.  Recorded URL historys and window geometry periodicly and and
gotten me back to where I was (mostly).  If it was supper cool, you could tie it
into talk back and respawn mozilla after a crash, right where (mostly) it left
off (minus sessioninfo and stuff like that). 

I love Mozilla so much.

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: [RFE] : Save state window states accross crashes. → [RFE] : Save state window states accross crashes.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.