Closed Bug 1872369 Opened 4 months ago Closed 19 days ago

Dropmarker control on the Password Manager Doorhanger is missing accessible name, role, and state

Categories

(Toolkit :: Password Manager, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Accessibility Severity s2

People

(Reporter: ayeddi, Unassigned)

References

(Blocks 3 open bugs)

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

Dropmarker control on the Username suggestion doorhanger is missing accessible name, role, and state which makes it inaccessible for assistive technology users and/or users of keyboard.

This element is functioning as a button to collapse/expand the list of autosuggestions, thus it should communicate it programmatically and to be allowed for keyboard-only users to focus and operate it.

<dropmarker xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" id="password-notification-username-dropmarker" class="ac-dropmarker"/>
Summary: Dropmarker control on the Username suggestion doorhanger is missing accessible name, role, and state → Dropmarker control on the Password Manager Doorhanger is missing accessible name, role, and state
See Also: → 1872379

Dropmarker control on the Username suggestion doorhanger is missing accessible name, role, and state which makes it inaccessible for assistive technology users and/or users of keyboard.

Dropmaker is functioning as a button to collapse/expand the list of autosuggestions, thus it should communicate it programmatically and to be allowed for keyboard-only users to focus and operate it.

The patch adds an accessible name, role, and state to the dropmaker image control.

This bug was flagged by 2 tests that were previously failing a11y_checks, thus we remove the fail-if notation from the appropriate test manifests, since these tests are now expected to be passing.

Team, I drafted the patch to resolve this blocker, but I need someone's help finalizing it: this patch creates an expected markup and provides expected accessibility support for the dropmarker control on init. But it still needs to be confirmed the dynamic functionality is as expected (refer to the inline comment for details). It needs a bit better understanding of the LoginManagerPrompter code that I do not have and I am not sure when and if I can get back to it.

Please do feel free to commandeer the revision and let me know if you have any questions.

The severity field is not set for this bug.
:serg, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(sgalich)
Severity: -- → S3
Flags: needinfo?(sgalich)
Priority: -- → P3

The severity field for this bug is set to S3. However, the accessibility severity is higher, .
:serg, could you consider increasing the severity?

For more information, please visit BugBot documentation.

Flags: needinfo?(sgalich)
Flags: needinfo?(sgalich)
See Also: a11y_checks_focusable
See Also: a11y_checks_labeled

In the current Nightly, the chevron dropmaker button is replaced with the accessible <button> that is labeled as More actions and it programmatically identifies that it has a popup. Not sure when it was fixed, but it is now.

Closing the bug and abandoning the patch.

Attachment #9370517 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 19 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: