images flicker on this webpage

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
P4
normal
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Biesinger, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20021230
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20021230

<spotted by IRCMonkey on irc.m.o>
alternative url: http://www.micronixmcu.com

The image "flickers" when it switches to the next one, instead of slowly fading
out and the next one in; compare with Netscape 7 or Mozilla 1.0.x to see it work
correctly.

So, there seems to be something wrong with the handling of MozOpacity...

Interestingly, after I switched to another application and then back to this
window, it seemed to work...

Reproducible: Sometimes

Steps to Reproduce:
1.load the page
2.wait a few seconds
3.watch the image flicker rather than correctly fading out and in

Actual Results:  
see above

Expected Results:  
see above

So... according to IRCMonkey, this does not work in 1.2.1 and 1.3a, and I
confirmed that with my trunk nightly from Dec. 30.

It does work in Netscape 7, as mentioned above.

looks like this is a regression.

hope this is the right component.
sigh, I meant to file this as unconfirmed, but it looks like bugzilla helper
doesn't let me...

Comment 2

15 years ago
i see only smooth fading images when testing with a current trunk CVS, Linux.

Comment 3

15 years ago
I see flickering on image under "You made this" letters with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20021230 under WinXP.

Comment 4

15 years ago
I see the flickering with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b)
Gecko/20021230.

The fading works with 1.2alpha but not with 1.2beta.

Comment 5

15 years ago
Under Linux 2002123022, I see them flicker (only when they appear; not when
disapperaing), and they use 100% CPU while they are fading.

Comment 6

15 years ago
Confirmed flicker under `YOU make this' when image fades in, 2002123022/Linux.

One interesting point to note is that the image does not display until the
flickers (fading) ends, i.e. there is only a box with alt text when it is
flickering. However, the arrow button provided on the page loads the image
immediately without the `loading box'.
The site is using percentage opacity, which causes reframes at the moment. 
There are no plans to fix this; in fact I'm hoping to remove percentage opacity,
since it's not in the CSS3 spec.

The site should be using numeric opacity instead.
Depends on: 83774
(Assignee)

Updated

15 years ago
Priority: -- → P4
Target Milestone: --- → Future

Comment 8

15 years ago
Now percentage opacity values have been disabled (see bug 195883) and the images
don't fade.
Marking worksforme; if the site fixes their code and this bug still persists,
please reopen.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.