Closed Bug 1872490 Opened 5 months ago Closed 1 month ago

Font Size options become disabled if computer settings sets Thundrebird px to 7 rendering Folder Pane, Message List, Message headers etc too small to read.

Categories

(Thunderbird :: Preferences, defect, P2)

Thunderbird 122

Tracking

(thunderbird_esr115 wontfix)

RESOLVED FIXED
127 Branch
Tracking Status
thunderbird_esr115 --- wontfix

People

(Reporter: anjeyelf, Assigned: aleca)

References

Details

Attachments

(1 file)

Windows 10 OS
Beta 122.0b1

If mail.uifontsize = 0 (default setting which seems odd as you would expect 12) then auto display px size is 12
If Menu app > Font Size is manually altered eg: decreased to 9px then mail.uifontsize = 9

In my case:

  • 9px is the minimum size I can set via Menu App > Font Size > +
  • alter mail.uifontsize to less than 9 and upon save the default 0 is set.

I have come across a couple of people who have auto discovered they are unable to alter the font size.
On these occasions the following is noticed:
mail.uifontsize = 0
Menu app > Font Size = 7px
Menu app > Font Size > + - and reset options are all disabled
Menu Bar toolbar - View > Font Size > increase/decrease font size options are disabled.

In Settings > General > Language & Appearance > 'Advanced' button:
they altered the sans-serif and serif font to use the same identical font
In once case 'Bookman Old Style'
This person was using Windows 11.
https://support.mozilla.org/en-US/questions/1433773

Another case - stuck on 7px :
https://support.mozilla.org/en-US/questions/1426742

Another case:
One person using Windows 11 - had same issue but discovered if they increased the font size setting in the computer settings this then made the font size increase in Thunderbird and also enabled all the Font Size options again.
https://support.mozilla.org/en-US/questions/1427420#answer-1620435

Another case:
In this instance person was using two screens and one is a 4k display which is likely to have caused a problem. Once that 7px setting is set it disables the Font Size options.

Current screen resolution is 3840x2160 as I'm using an external monitor, but the issue is still the same with the built-in 1920x1080 screen.
Scale setting for this external 4k monitor is 200%.
With the above settings, the Font Size controls are still unusable and stuck at 7px (like in the original screenshot I attached), which makes Folder Pane, Menus and Message List too small to read. The only way so far for me to make these fonts larger was to modify mail.uifontsize value from the default 0 to something larger like 10 or 12 - that causes Font Size controls to start working again.
https://support.mozilla.org/en-US/questions/1426742

Discovered:
altering the ' layout.css.devPixelsPerPx' effected Font Size. But, I'm trying to get people to leave that set as default and alter Font Size via menu options for Font Size. It was used as a test only.
Also manually altering the mail.uifontsize = 12 also allowed the Font Size options to become enabled again.

This bug issue - it may have been that the computer settings for font px size set Thunderbird as a setting too low which disabled all abilities to increase the font. Perhaps a manual alteration or scaling used in 4k / retina ?

If mail.uifontsize = 12 by default would this help to resolve ?

Summary: Font Size options become disabled if computer sets px to 7 → Font Size options become disabled if computer settings sets Thundrebird px to 7 rendering Folder Pane, Message List, Message headers etc too small to read.

Yes, when users manipulate the font scaling in Windows, you'll get some strange effects. Somehow TB takes the Windows setting into account:
https://searchfox.org/comm-central/rev/f382c664f6c6d6bbb23771103c02ee9e3dfdac1d/mail/modules/UIFontSize.sys.mjs#152
and it also blocks the UI here:
https://searchfox.org/comm-central/rev/f382c664f6c6d6bbb23771103c02ee9e3dfdac1d/mail/modules/UIFontSize.sys.mjs#195-200
The code in question is from bug 1715364.

See Also: → 1715364
Flags: needinfo?(elizabeth)

I want to test this.

Thank you for reporting this issue.

More info gathered from Support Forum.
It's not necessarilly people manually altering scaling.
It's occuring when people use 4K (UHD) screens. They are using whatever the computer was preset with 'recommended' settings.
eg:
Computer is Dell S2721QS Color Profile
scale resolution: 3840 x 2160
Scale : 150%

This 4K has the effect of setting Thunderbird with 7px and therefore not exactly readilble.
Thunderbird does not auto allow to go down as far as 7px. You cannot actually choose to decrease down to 7px.
Thunderbird still has preference 'mail.uifontsize' as 0.
Result means all Font Size increase/decrease/reset options get disabled until you manually set 'mail.uifontsize' to a size eg: 12

Thanks for this added information, Anje.

See Also: → 1865615

I have an idea on how to fix this, and I will use the occasion to add some tests to cover the scenario.

Assignee: nobody → alessandro
Flags: needinfo?(elijmitchell)
Severity: -- → S3
Priority: -- → P2
Attachment #9397509 - Attachment description: WIP: Bug 1872490 - Fix UIFontSize for web browser, locking the app menu options, and add tests. → Bug 1872490 - Fix UIFontSize for web browser, locking the app menu options, and add tests. r=#thunderbird-front-end-reviewers
Attachment #9397509 - Attachment description: Bug 1872490 - Fix UIFontSize for web browser, locking the app menu options, and add tests. r=#thunderbird-front-end-reviewers → Bug 1872490 - Fix UIFontSize to prevent locking the app menu options and add tests. r=#thunderbird-front-end-reviewers
Status: NEW → ASSIGNED
Target Milestone: --- → 127 Branch

Pushed by martin@humanoids.be:
https://hg.mozilla.org/comm-central/rev/5dbebc71617f
Fix UIFontSize to prevent locking the app menu options and add tests. r=freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Regressions: 1893107
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: