Backspace for Navigation and Typeahead and don't go well together

VERIFIED DUPLICATE of bug 177005

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 177005
15 years ago
15 years ago

People

(Reporter: Daniel Kabs, reporting bugs since 2002, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2.1) Gecko/20021130

Now that Typeahead Find is implemented I had to learn it the hard way that
backspace has several "meanings": You can correct the search word using BS but
if Typeahead Find is cancelled a BS sends you one page back in history. That's
bad!

I suggest a preference setting for disabling backspace navigation!

Cheers

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

15 years ago
Perhaps we should reopen bug 177005.

My fix was to beep and require 1 more backspace. Perhaps the fix should have
been to disabled backspace when typeaheadfind starts, until typeahead is
cancelled by some other means than backspace.

*** This bug has been marked as a duplicate of 177005 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

15 years ago
I don't want backspace to do any navigation as it produces many mistakes on
pages with forms.
Thus I reconfigured the key bindings in  platformNavigationBindings.xul:
Remove 

    <!-- Supporting IE forward and back accelerators out of courtesy
         to transitioning IE users -->
    <key keycode="VK_BACK" command="Browser:Back"/>
    <key keycode="VK_BACK" command="Browser:Forward" modifiers="shift"/>

and backspace navigation is no longer a problem.
You need to log in before you can comment on or make changes to this bug.