Filters unable to work (sometimes because of "folder busy" condition)

VERIFIED DUPLICATE of bug 168648

Status

MailNews Core
Filters
VERIFIED DUPLICATE of bug 168648
15 years ago
9 years ago

People

(Reporter: Keith Jillings, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212


Happens only at startup, when there is a large batch of incoming mail.

Mozilla reports that filters are unable to process mail because another
operation is in progress.   Mail is put into "basic" inbox without filtering.  

I operate several different accounts at several ISPs;  this usually happens when
there is inmail to more than one of them.   Mail isn't filtered, so mail to the
less-used accounts goes into mailboxes at the bottom of the list, and unless I
scroll down (which I rarely do), I miss it.

If I'm at the PC, I see the message that Mozilla was unable to filter, and can
check.


Reproducible: Sometimes

Steps to Reproduce:
1.   Log off, and don't check e-mail for a day or so.
2.   Log on.
3.   Usually get the message while the machine is downloading mail.

Actual Results:  
90% or more of mail filtered correctly.   A few items (typically two or three
out of 50 or more) put into "other account" inboxes.

Expected Results:  
Filtered mail to "Main" inboxes where there is a detailed table of inmailboxes
by subject.

Comment 1

15 years ago
Are you filtering from one account to another? (so it seems from the use of
"basic" and "main" inbox wording).  
Is mail in each account set to auto retrieve mail at some small interval maybe,
potentially exacerbating the situation?
What kinds of accounts?
Are passwords remembered?
It may be that your particular filter setup is problematic, don't know.

We did implement the "don't filter if folder/mailbox is busy" idea to avoid
potential issues with mail message loss when filters were firing.  This sounds
like it's working in your case.  
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Filters unable to work → Filters unable to work (sometimes because of "folder busy" condition)
(Reporter)

Comment 2

15 years ago
I posted a reply a week ago - it seems to have disappeared...

Yes, I am filtering between accounts.   I have 12 separate ones, with several
different ISPs.   I filter most of the mail to one set of folders.  That works
OK 99% of the time, but usually gives this error when I first connect to the Net.

They are all POP accounts.   Passwords are remembered by Mozilla.

It could be the "don't filter if busy" feature - that would be consistent.  But
given that the "busy" state is transient, can it not queue them?
mass re-assign.
Assignee: naving → sspitzer

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 168648 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.