SMTP password crashes Mozilla

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: mozilla, Assigned: sspitzer)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

Either by a glitch or an operator (ie my) error, one of my several ISP accounts
picked up a flag in its SMTP settings to ask for a password before sending mail.
  That ISP doesn't require a password if the user is logged on.   Therefore,
there is no "valid" password and trying to input one causes a rejection.   The
mail is not sent.

Once I'd tried to send an e-mail to that ISP, the Moz 1.3a system wouldn't let
me edit the settings for any account.   It just froze, using 98% of system
resources, and needed a Ctrl-Alt-Del to close it.

Restarting the machine and going direct to "Edit settings" still crashed 1.3a. 
 In the end, I started 1.2b and was able to get into the settings, go to
"Outgoing Server (SMTP)" and turn off the "password required" setting.

Reproducible: Didn't try

Steps to Reproduce:
1.   I daren't try.   It crashes and can only be cured by closing the program.
2.
3.



Expected Results:  
Showing "password required" for a particular SMTP setting when no password is
required should not crash the system.

Comment 1

16 years ago
You might copy the appropriate line from prefs.js to user.js so that it doesn't
revert.

Updated

16 years ago
QA Contact: laurel → nbaca

Updated

16 years ago
Blocks: 193931
Keywords: crash

Comment 2

16 years ago
Reporter, to troubleshoot this problem, please follow these steps. When you
reply, make sure to include your operating system version, and the build ID. The
build ID is located in the Mozilla title bar. If the problem is sovled, please
indicate what step solved it.

1. Make sure that the test machine you're running is in good condition. On
Windows 9x, run scandisk. On Windows NT/2000/XP, error-check the drives. On
*nix, check for filesystem errors. Furthermore, if you have an antivirus
program, make sure the antivirus definitions and program files are up to date.
Make sure you have recently scanned the system for viruses, and removed any you
find. Once this is complete, can you still reproduce the problem?

2. Download and install the latest trunk nightly build.  Running a nightly build
has a slight amount of risk involved. Back up your Mozilla data including your
bookmarks before proceeding. You can download the latest nightly build from
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest . For example, for Windows,
download the file mozilla-win32-installer-sea.exe. Uninstall your current
Mozilla build. Make sure the new directory where you will install the new build
is completely empty, except for any plugins subdirectory. Install the nightly
build. Having done that, can you still reproduce the problem?

3. If it still fails, exit Mozilla. Go to your profile directory. Find the file
xul.mfl (or xul.mfasl on *nix). Rename it. Restart Mozilla. Does that solve the
problem?


Before following the next steps, create an SMTP log. Attach the SMTP log to this
bug. The steps for creating the log can be found here:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap


4. Is the computer you are running Mozilla on running an antivirus program? If
so, please detail what program and what version it is. Temporarily disable the
antivirus program. Then try to reproduce the problem you describe. Does the
problem still occur?

5. Go to Edit | Mail & Newsgroup Account Settings | Outgoing Server (SMTP) and
check "never" on whether to use a secure connection (SSL). Now try to reproduce
the problem. Does it still occur?

6. Go to Edit | Mail & Newsgroup Account Settings. In the appropriate account,
under Copies & Folders, unselect "place a copy in." Now try to reproduce the
problem. Does it still occur? If this works, is this an IMAP account? Are there
many messages in the sent folder?

7. Is the computer behind a firewall? If so, temporarily disable it, or put the
computer directly on the Internet. Can you still reproduce the problem? If not,
what product and version number is the firewall?

8. Delete all your SMTP server entries. Exit Mozilla. Restart Mozilla. Recreate
all your SMTP server entries. Can you still reproduce the problem?

9. Do you have spellchecker installed? If so, disable it or remove it. Does that
solve the problem?

10. Is your profile hosted on a network drive (or NFS mount)? 

If none of these steps work, please attach an SMTP log. 

Comment 3

16 years ago
Keith Jillings, is this bug still a problem for you?  Have you followed the 
suggestions from comment 2?  Have you upgraded to a more current build (1.3 or 
1.4) of Mozilla?
(Reporter)

Comment 4

16 years ago
As I mentioned in the original report, the effect of the bug was too severe for
me to risk trying to reproduce it.

However, I'm now on 1.4RC2, and it hasn't recurred since 1.3a so mark it "gone
away".   
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.