Closed Bug 1872983 Opened 2 months ago Closed 2 months ago

Tooltips have solid background beneath their arrows

Categories

(DevTools :: Shared Components, defect, P2)

Desktop
All
defect

Tracking

(firefox-esr115 unaffected, firefox121 unaffected, firefox122 unaffected, firefox123 verified, firefox124 verified)

VERIFIED FIXED
123 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox121 --- unaffected
firefox122 --- unaffected
firefox123 --- verified
firefox124 --- verified

People

(Reporter: nchevobbe, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

This is visible in the tooltip we have for css variable, but also for the devtools menu and more (see screenshot)

mozregression points to Bug 1872399

Keywords: regression
Regressed by: 1872399

:emilio, since you are the author of the regressor, bug 1872399, could you take a look? Also, could you set the severity field?

For more information, please visit BugBot documentation.

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

Before the first part of bug 1872399, that would use
WindowShadow::Default, which didn't create a vibrant effect etc, which
causes the background here.

Make it more explicit by calling this "Panel". The second part of
bug 1872399 already did this.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60812053dbd7
Restore behavior of -moz-window-shadow: auto and appearance: none. r=dholbert
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 123 Branch
Flags: qe-verify+

I managed to reproduce this issue in Nightly v123.0a1 (2024-01-04) in both MacOS 11 and also an even worse looking tooltip in Windows 10. I confirm the fix in Beta v123.0b5 and the latest Nightly v124.0a1.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
OS: Unspecified → All
Hardware: Unspecified → Desktop
You need to log in before you can comment on or make changes to this bug.