favicon.ico drawing code prefers 8-bit icons over 32-bit icons even on deep displays

RESOLVED WONTFIX

Status

Camino Graveyard
General
--
minor
RESOLVED WONTFIX
15 years ago
15 years ago

People

(Reporter: Charles Wiltgen, Assigned: saari (gone))

Tracking

Details

(Whiteboard: patch resides in bug 109862?, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021231 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021231 Chimera/0.6+

When you go to http://playbacktime.com/, you *should* see a 32-bit favicon (with
a nice, alpha-masked edge) when using a display mode greater than 8 bits per
channel.

Instead, the favicon.ico drawing code is drawing the 256-color icon in
favicon.ico even though a 32-bit icon is available.  Apparently, the favicon.ico
drawing code gives precendence to 8-bit icons over 32-bit icons.  The 32-bit
icon should be drawn (with its alpha mask) in this case.

As a workaround, I'm going to have to faux-anti-alias the 256-color icon against
white.  This means the icon won't look quite right against non-white backgrounds.

Reproducible: Always

Steps to Reproduce:
1. Create a favicon.ico file with 8-bit and 32-bit icons.
2. Put the favicon.ico file in the root folder of your site.
3. Go to that site.

Actual Results:  
The 8-bit icon is displayed.

Expected Results:  
The 32-bit icon can and should be displayed.

Using latest nightly build of Chimera.
hmm, right... this was never fixed on the 1.0 branch of mozilla...

this would be a duplicate of bug 109862. It was fixed on May 14 last year on the
mozilla trunk.

if you want this to get checked in on the 1.0 branch as well, please comment in
that bug.

marking duplicate.

*** This bug has been marked as a duplicate of 109862 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
As this bug is not critical for Gecko 1.0.x stability, I doubt it will be fixed
in the Mozilla 1.0.x. Chimera is not on the 1.0 branch though, but on the
"CHIMERA_M1_0_1_BRANCH", so we can add addition patches, and imho, this should
be one of them. Therefore reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
And confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: patch resides in bug 109862?

Comment 4

15 years ago
Er, Chimera doesn't use the Mozilla favicon code at all. Chimera just throws the
favicons at NSImage, so this would be a Cocoa bug. File a bug with Apple.
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.