images are showing up broken, even though they are working; browser looking for file incorrectly

VERIFIED DUPLICATE of bug 187323

Status

SeaMonkey
Bookmarks & History
--
major
VERIFIED DUPLICATE of bug 187323
15 years ago
13 years ago

People

(Reporter: M. Turner, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

I'm having issues with broken images all over Mozilla. The same images show up
just fine in Netscape 6.2 and IE 5 on the same system. I'm confused, but it
seems there is a difference whether the images are listed as being
http://www.domain-name.com/image.jpg or http://domain-name.com/image.jpg In the
latter, it's not showing up, but if you add the "www" to the address of the very
same image, it shows up successfully.

An example is this image:
http://members.aol.com/xxrolettexx/images/me1.jpg

I get this error when it attempts to find the server:
The file /xxrolettexx/images/me1.jpg can not be found. Please check the location
and try again.

It looking for it as a file without the http:// and domain information? I
clearly entered it with that information.

I'm using the following:
Mozilla 1.2.1

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

On Windows 98SE with RoadRunner Cable Modem.

Help?

Reproducible: Always

Steps to Reproduce:
1. Surf web. Image that you know to be correct is broken.
2. Right-click - View Image and instead of getting image, will get the following
error: "The file /filename.jpg can not be found. Please check the location and
try again."
3. Add in "www" to the address of the image in the to address bar.
4. Image loads successfully
Actual Results:  
If you manually add in the "www" after the "http://" the image loads. If you do
not (or can not, such as on a page which contains images and you can not edit
the source code), the image simply will not load.

Expected Results:  
Load the image with or without the inclusion of "www" in the address.

http://domain-name.com/image.jpg SHOULD work just fine. It does not. It instead
requires it to be http://www.domain-name.com/image.jpg

For some reason, it seems (by the error message) to be looking for the image as
a LOCAL file and not a web file without the www included.

This means, when surfing, I randomly encounter "broken" images which are not
actually broken at all. This is an especial hinderance when the images are used
in an image map for navigation on a site - you can no longer navigate the site.
(an example is the image maps on www.neopets.com such as seen on this page:
http://www.neopets.com/objects.phtml and this page:
http://www.neopets.com/explore.phtml )

Mozilla 1.2.1

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

On Windows 98SE with RoadRunner Cable Modem.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 187323 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.