crash when clicking in menubar while page loading [@ nsXULTooltipListener::DestroyTooltip ]

VERIFIED DUPLICATE of bug 185020

Status

()

Core
Event Handling
--
critical
VERIFIED DUPLICATE of bug 185020
15 years ago
11 years ago

People

(Reporter: Jo Hermans, Assigned: saari (gone))

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
Once in a while I have a crash when I click in the menubar (edit- or view-menu)
while a page is loading. For instance when I want to open the preferences
immediately after startup, but I didn't notice that my homepage wasn't
completely loaded. Or when I want to open page-info on a page that is still loading.

Most of the time it works, but sometimes Mozilla will crash, or even the entire
computer will hang. An example of this is talkback-trace TB15653965H. It doesn't
seem to be a problemn in Mozilla itself (it only happens with the native
menubar, not with the toolbar-popups for instance), but more an interaction
between Mozilla and the OS (for the native menubar).

build 2002122708 on Mac OS 9.2.2. Hardware is iBook 300 MHz.
(Reporter)

Updated

15 years ago
Keywords: crash, stackwanted
Whiteboard: TB15653965H

Updated

15 years ago
Severity: normal → critical

Comment 1

15 years ago
Jo, can you try again with a nightly build ?
This may have been altered since with patch for bug 179567.
Assignee: asa → saari
Component: Browser-General → Event Handling
QA Contact: asa → trix
0x003b009c
nsXULTooltipListener::DestroyTooltip() [nsXULTooltipListener.cpp, line 652]
nsXULTooltipListener::HideTooltip() [nsXULTooltipListener.cpp, line 519]
nsXULTooltipListener::sAutoHideCallback() [nsXULTooltipListener.cpp, line 697]
nsTimerImpl::Fire() [nsTimerImpl.cpp, line 383]
handleTimerEvent() [nsTimerImpl.cpp, line 448]
PL_HandleEvent() [plevent.c, line 663]
PL_ProcessPendingEvents() [plevent.c, line 593]
nsEventQueueImpl::ProcessPendingEvents() [nsEventQueue.cpp, line 388]
nsMacNSPREventQueueHandler::ProcessPLEventQueue() [nsToolkit.cpp, line 182]
nsMacNSPREventQueueHandler::RepeatAction() [nsToolkit.cpp, line 147]
Repeater::DoRepeaters() [nsRepeater.cpp, line 136]
nsMacMessagePump::DispatchEvent() [nsMacMessagePump.cpp, line 501]
nsMacMessagePump::DoMessagePump() [nsMacMessagePump.cpp, line 313]
nsAppShell::Run() [nsAppShell.cpp, line 120]
nsAppShellService::Run() [nsAppShellService.cpp, line 471]
main1() [nsAppRunner.cpp, line 1543]
main() [nsAppRunner.cpp, line 1904]
.__start 
Keywords: stackwanted
Whiteboard: TB15653965H

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 185020 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: crash when clicking in menubar while page loading → crash when clicking in menubar while page loading [@ nsXULTooltipListener::DestroyTooltip ]
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsXULTooltipListener::DestroyTooltip ]
You need to log in before you can comment on or make changes to this bug.