Reloading a page with an applet halts Mozilla.

VERIFIED DUPLICATE of bug 16296

Status

P3
critical
VERIFIED DUPLICATE of bug 16296
20 years ago
8 years ago

People

(Reporter: leila.garin, Assigned: edburns)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Using 11/12/99 build of Mozilla and latest build of jdk1.3 (JDK1.3.0-O)
on WinNT. This doesn't happen on MAC.

To reproduce,
- Run mozilla.exe.
- Load an applet.
  http://javaweb/~marklin/flame/flame.html
- Reload.

This will halt mozilla. If you brought up the Java Console, you'll see
NullPointerExceptions.

Updated

20 years ago
Assignee: drapeau → edburns

Comment 1

20 years ago
Windows breakage; re-assigning to Ed since he's already looking at the general
problem.
(Assignee)

Updated

20 years ago
Assignee: edburns → ryang
(Assignee)

Comment 2

20 years ago
I'm seeing this bug with the latest mozilla and 1.3 JDK.  Mozilla hangs with
the console spewing this endlessly:

Exception occurred during event dispatching:
java.lang.NullPointerException: component argument pData
        at sun.awt.windows.WGraphics.createFromComponent(Native Method)
        at sun.awt.windows.WGraphics.<init>(Unknown Source)
        at sun.awt.windows.WComponentPeer.getGraphics(Unknown Source)
        at java.awt.Component.getGraphics(Unknown Source)
        at sun.awt.RepaintArea.update(Unknown Source)
        at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
        at java.awt.Component.dispatchEventImpl(Unknown Source)
        at java.awt.Container.dispatchEventImpl(Unknown Source)
        at java.awt.Component.dispatchEvent(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)

Comment 3

20 years ago
See bug 14712 for questions on reloading of a plugin in Mozilla.  Briefly,
something appears to be broken with reloading.  I need info on the correct
sequence of OJI calls for a Mozilla plugin, or else the Java Plugin will not
work on reloads.

Updated

19 years ago
Assignee: ryang → edburns
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

19 years ago
*** This bug has been marked as a duplicate of 16296 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Verfied as a dup.

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.