If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

saves zip file as a php file

RESOLVED DUPLICATE of bug 65827

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 65827
15 years ago
a year ago

People

(Reporter: grant, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

at the url above or any page where you could possibly save a zip file.  Mozilla
seems to save the file with a php extension instead of the zip extension.

Reproducible: Always

Steps to Reproduce:
1.click on the zip file link
2.wait for it to download
3.once finished the file is now a php file

Actual Results:  
the downloaded file had a php extension.  eg. blah.zip.php

Expected Results:  
save the downloaded file with the correct extension
-> file handling
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: asa → petersen
Is it just saved with the wrong extension?  Or is it also unzipped?  That is, if
you rename it, do you get a proper zip file?

Comment 3

15 years ago
I think this is a dupe of bug 111470 (filed Nov. 2001).  They're reporting it as
a Tech Evangelism issue but don't specify if the issue is PHP or the web-server
config.

*** This bug has been marked as a duplicate of 65827 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.