Closed Bug 187408 Opened 17 years ago Closed 6 years ago

microsoft.com - Windows Online Crash Analysis doesn't allow bug submittal with Mozilla

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: lmorley, Unassigned)

References

()

Details

(Keywords: top100, top500)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

I've only discovered this issue since XP SP1, as with all previous releases
Windows Crash Analysis always went through IE regardless of my primary browser.

Now, because of my custom options under "Set Program Access and Defaults"
(elaborated on below), Online Crash Analysis now opens up in Mozilla. Due to
what seems to be a Evangelism issue, I get the following message:

"Requirements

To track the status of an error report, you must be running Internet Explorer 5
or later or Netscape version 6 or later, and you must have a valid Microsoft
Passport. To download the latest version of Internet Explorer, visit the
Microsoft Web site. To get a Passport, visit the Microsoft Passport Web site.

For Windows 2000 error reports, a Premier account is required. For more
information about Premier accounts, see Product Support Services on the
Microsoft Web site.

The Windows Online Crash Analysis Web service requires that both JavaScript and
cookies are enabled in your browser in order to retain and display your customer
data while navigating through the site. JavaScript is used to create dynamic
content on the Web pages. All cookies used by the WOCA service are memory
cookies and expire when you navigate away from the WOCA site or close your
browser. This information is used by our service to retain your preferences
while using the site. No personal information is written to your hard drive or
shared outside of our service.

Microsoft Passport also requires JavaScript support and cookies. To find out
more about the Microsoft Passport service and requirements, visit the Microsoft
Passport Web site."

I'm assuming this is a server-side code issue. It's either an evangelism issue,
or Mozilla somehow doesn't support passport/etc as Microsoft would have it-
which seems impossible due to the fact that it says Netscape 6+ is fine.

Reproducible: Always

Steps to Reproduce:
1. set up windows xp (must be SP1!) with the following option under "set program
access and defaults" (found in the same area as "add or remove programs")

choose a default browser:
(x) use my current browser (if mozilla is set to be the default browser- there
is no option for mozilla, it only sees IE and netscape.)
[x] allow access to IE.

I'm assuming options for mail, media, and messaging have no impact; just in case
it's relevant, however, I've denied access to Windows Messenger as well as the
MS JVM.
2. crash windows (oh, i wish this were more difficult)
3. submit bug report
4. wait for mozilla browser to come up

Actual Results:  
A page with the following text appears:

"Requirements

To track the status of an error report, you must be running Internet Explorer 5
or later or Netscape version 6 or later, and you must have a valid Microsoft
Passport. To download the latest version of Internet Explorer, visit the
Microsoft Web site. To get a Passport, visit the Microsoft Passport Web site.

For Windows 2000 error reports, a Premier account is required. For more
information about Premier accounts, see Product Support Services on the
Microsoft Web site.

The Windows Online Crash Analysis Web service requires that both JavaScript and
cookies are enabled in your browser in order to retain and display your customer
data while navigating through the site. JavaScript is used to create dynamic
content on the Web pages. All cookies used by the WOCA service are memory
cookies and expire when you navigate away from the WOCA site or close your
browser. This information is used by our service to retain your preferences
while using the site. No personal information is written to your hard drive or
shared outside of our service.

Microsoft Passport also requires JavaScript support and cookies. To find out
more about the Microsoft Passport service and requirements, visit the Microsoft
Passport Web site."

Expected Results:  
The bug is submitted.
Liam, if it works with your ua string set to Netscape 6 then it is a simple
server side change in their ua detection. Can you test it with a NS6 ua string? 
Blocks: MS
Summary: oca.microsoft.com - Windows Online Crash Analysis doesn't allow bug submittal with Mozilla → microsoft.com - Windows Online Crash Analysis doesn't allow bug submittal with Mozilla
*** Bug 187725 has been marked as a duplicate of this bug. ***
RenA confirmed that the issue is NS only ua detection.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: evang500
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us
i just recently accidentally tried running windows update from Mozilla, and
received a new message- this time it says to only use IE. So apparently you
can't use Netscape anymore either... which means it's no longer an Evangelism
bug (or a bug at all), right? it's "fixed"?
Liam, windows update is different from this I think. Windows Update uses ActiveX
and as such has never been supported.
Windows Update is bug 28321.
Bob,

what was i thinking. i plead temporary stupidity.
Keywords: top500
Keywords: top100
Is this still an issue ?
URL is obsolete.
[closeme]
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.