Closed Bug 18741 Opened 20 years ago Closed 20 years ago

[DOGFOOD] Loading a page that uses LiveConnect crash mozilla.

Categories

(Core Graveyard :: Java: OJI, defect, P3, critical)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: leila.garin, Assigned: drapeau)

References

()

Details

(Whiteboard: [PDT+] 02/08-Need Java enabled to verify.)

Attachments

(1 file)

Using 11/12/99 build of Mozilla and latest build of jdk1.3 (JDK1.3.0-O)
on WinNT. This doesn't happen on MAC.

To reproduce,
- Run mozilla.exe.
- Load a page that is using LiveConnect. For ex.,
http://lonely/blackwood_qa/src/OJI/PluginTest/sunw/LiveConnect/html/getWindowLC.html

  After the page is loaded, it kills mozilla.
Status: NEW → ASSIGNED
Hi Leila,

Do you happen to have a stack trace or any other kind of crash-time info that
you can put in here?
On the VC++ debugger, it gives (
 Unhandled exception in mozilla.exe (JSJ3250.DLL); 0xC0000005; Access Violation
Summary: Loading a page that uses LiveConnect kills mozilla. → [DOGFOOD] Loading a page that uses LiveConnect kills mozilla.
Using Mark Lin's kestrel build and 12/16/99 Mozilla build from RE on Solaris,
I've verified that loading any page with LiveConnect kills Mozilla.
Whiteboard: [PDT-]
Can we get this retested on current build?
Also, live connect is not PDT+.
Using 12/21/99 M12 build and jdk1.3 build "P" on WinNT, this bug is
reproduceable.
Leila, could you attach the test case. The url named is not accessible outside
of Sun. Thanks.
there are a bunch of live connect pages off this search on yahoo.
http://ink.yahoo.com/bin/query?p=%22live+connect%22&hc=0&hs=0
I tried a few with the netscape commercial build of 02/01/00
but the applets on the pages didn't seem to load so I'm not sure I've
got java set up right after installation.  Can someone check a few 
of these pages out and let us know if we are ok with latest builds? paw?

should liveconnect work for beta1?  is it in the beta criteria doc?
putting on the beta1 radar.  lets mark it fixed if the the problem
no longer exists.
Keywords: beta1
Summary: [DOGFOOD] Loading a page that uses LiveConnect kills mozilla. → [DOGFOOD] Loading a page that uses LiveConnect crash mozilla.
removing the pdt- for dogfood.
Whiteboard: [PDT-]
Currently Java is not working in the builds. I will check these pages out when Java is enabled.  Looks like there is a new JRE 1.3.   
When I get it, I will verify.
paw...marking Resolved/Fixed for the crash. If no crash, please mark verified 
for this bug.  If LiveConnect is not working, this is a new bug.  Putting on 
PDT+ radar for beta1 in case crash is still there.

chriss, is LiveConnect IN for beta1?
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+]
Putting Status Summary "need java" comments in.
Whiteboard: [PDT+] → [PDT+] 02/08-Need Java enabled to verify.
- If Java is in for beta1 (TBD), then Java<-->JavaScript LiveConnect is in. If 
it's not, it's not. 
- We expect to have a working JVM drop from Sun internally at a minimum by M14. 
Whether we have working Java for beta depends on the resolution of bug 23672.
- JavaScript<-->plug-in LiveConnect is in in the sense that if a plug-in vendor 
upgrades their plug-in to the Mozilla Plug-in API, then existing LiveConnect 
calls to the plug-in API from JavaScript will continue to work. This is now 
really a separate issue from Java<-->JavaScript LiveConnect since 
JavaScript<-->plug-in LiveConnect no longer depends on the presence of a JVM (as 
it did in Nav4), but because the term "LiveConnect" is overloaded I'm noting 
this here for completeness.
I was able to successfully run our JS to Java and Java to JS live-wire tests but I am not able to check the url for this bug.  Could 
someone at Sun check this out since the site is behind the firewall.  Thanks.
Tested on WinNT4.0 with SP5.

Used mozilla nightly build dated 03/05/2000 with JRE- RC1 (from JDC site).
Used patched plugin zip file (from George).

Tested the URL above. The result is displayed correctly.

Verified in build 2000030608-M15.  Original url verified by rpallath@eng.sun.com.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.